IM Manager Exports Duplicate Conversations to Enterprise Vault (EV) When There are Errors During the Export Process

Article:TECH137604  |  Created: 2010-08-11  |  Updated: 2011-02-11  |  Article URL http://www.symantec.com/docs/TECH137604
Article Type
Technical Solution

Product(s)

Issue



IM Manager is configured to export directly to EV.  You find that EV contains the same IM conversations multiple times. The following is an example: 

 

 

Symptoms

 

  • The export history shows less than 100% completion and an error message.

1. Open the IM Manager Administration Console.
2. Click the Administration tab.
3. Click Configuration > Export on the left hand menu.
4. Click the history hyperlink for the EV export job.

 

Conditions

 

  • Export job is created as an integrated EV export job.

    1. Open the IM Manager Administration Console.
    2. Click on Administration tab.
    3. Click on Configuration > Export.
    4. Click the Edit hyperlink for the EV export job.

 

If there is an EV Directory DNS Alias textbox then the export job is an integrated EV export job.

  • Export job is not configured to export archived messages.


1. Open the IM Manager Administration Console.
2. Click on Administration tab.
3. Click on Configuration > Export.
4. Click the export hyperlink for the approrpriate export job.

5. If the checkbox Include Archived Messages is not checked then this condition is met.

If the checkbox is checked then IM conversations are always exported to EV each time the export job runs regardless of whether they have been exported previously.

  • An error has occurred during the export job.

1. Open the Windows application event log.
2. Find the start of the EV export:


Information 115 1/11/2008 0:31 IMLogicAdminService SYMANTECSRV01 None SYMANTEC\imlogic IM Manager Archiving task has started for account Enterprise Vault.


3. After the start event the windows application event log shows an error message.


The following is an example.  However it may be any other error message.


Event Type: Error
Event Source: IMLogicAdminService
Event Category: None
Event ID: 113
Date:  12/14/2007
Time:  11:44:13 AM
User:  SYM\svc_evault
Computer: SYMANTEC01
Description:
Error 0x80020009 processing input file C:\IMManagerExports\EnterpriseVault\IML1.xml.
Description: Exception occurred.
. Failed conversation was moved to C:\IMManagerExports\EnterpriseVault\errors\Error-IML1.xml

 

 


Cause



If the direct EV export job encounters any error during the export process no conversations are marked as exported.  The next time the job runs it may re-export the same messages.  This results in duplicate IM conversations in EV.


Solution



This issue has been resolved as of IM Manager 8.4.16.

Please upgrade to the lastest version of IM Manager to resolve this issue.


Supplemental Materials

SourceETrack
Value2094058
Description

IM conversations not marked as exported to EV (Enterprise Vault) when some of the conversations have XML transformation errors


SourceETrack
Value2101790
Description

Need to set EV Metadata Vault.MsgDirection when inserting IM Conversation into EV through API



Article URL http://www.symantec.com/docs/TECH137604


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