Backup of Microsoft Office Sharepoint Server (MOSS) 2007 Search Index fails with an AOFO initialization failure.

Article:TECH140483  |  Created: 2010-09-22  |  Updated: 2011-09-27  |  Article URL http://www.symantec.com/docs/TECH140483
Article Type
Technical Solution


Subject

Issue



Backups of Search Index databases fail with an AOFO Initialization failure mid-backup when protecting Sharepoint Farm resources using the Backup Exec Sharepoint Agent.  De-selecting the Sharepoint Search Index Resource allows for successful backup completion.

 


Error



From Backup Exec:

AOFO: Initialization failure on: "search instance\Index files 1 (server\GUID)". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS)

Snapshot provider error (0xE00084AF): The directory or file was not found, or could not be accessed.

 

From the Application Event log on the Microsoft Office Sharepoint Server (MOSS) Web Application server:

Event Type: Error
Event Source: Windows SharePoint Services 3 Search
Event Category: Gatherer
Event ID: 10029
Computer: SERVER1
Description:
Error backing up registry hive to the configuration database.
Context: Application 'Search index file on the search server'

Details:
Registry backup failed because of a version mismatch. (0x8004122b)
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

 Event Type: Error
Event Source: Windows SharePoint Services 3 Search
Event Category: Gatherer
Event ID: 2426
Computer: SERVER
Description:
Advise Status Change failed. The system is probably low on resources. Free up resources and restart the service.
Context: Application 'Search', Catalog 'index file on the search server Search'

Details:
(0x80041812)
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Environment



These issues occur on Microsoft Office Sharepoint Server (MOSS) 2007 farms utilizing search index databases.


Cause



Usually related to low system resources, such as insufficient disk space on the drive which stores the index or low memory.


Solution



It may be necessary to repair the search index database to allow for a consistent VSS snapshot and resolve the resource condition that caused the corruption.

Contact Microsoft Technical Support for assistance repairing the Search Index.

 


Supplemental Materials

SourceEvent ID
Value2426
Description

Advise Status Change failed. The system is probably low on resources. Free up resources and restart the service.


SourceEvent ID
Value10029
Description

Error backing up registry hive to the configuration database.
Context: Application 'Search index file on the search server'




Article URL http://www.symantec.com/docs/TECH140483


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