Error, "Failed in OnMessage handler of Application Inventory Task: Unable to update"
| Article:TECH14061 | | | Created: 2006-05-25 | | | Updated: 2009-04-28 | | | Article URL http://www.symantec.com/docs/TECH14061 |
Problem
I receive the following error message:
Failed in OnMessage handler of Application Inventory Task: Unable to update the specified item from the Altiris NS database.
Environment
Windows 2003 Server SP1 on the Notification Server
Windows 2003 Server SP1 on the SQL Server (SQL* 2000 SP3)
Notification Server 6.0 SP3
Software Delivery Solution 6.1 (Hotfix 1)
Inventory Solution 6.1
Application Metering Solution 6.0
Cause
Suspected cause is task corruption.
Solution
- On a test server or another Notification Server, find the Task located under View > Solutions > Software Delivery > Configuration > Windows > Application Inventory. It is named "New Application Inventory Task."
- Note that this task must be the default Application Inventory task that comes as part of the Software Delivery installation.
- Right-click on the task and choose Export.
- Open the resulting XML file in a true XML editor (www.crimsoneditor.com)
- Search for the word NoDelete. It will be within the Attributes tags.
- Delete this so that NoDelete no longer appears within the Attributes tags. Save the changes to the file.
- Take the resulting XML file and move it to the Notification Server experiencing this problem.
- In the console of the Notification Server with the issue, browse to the same location as above.
- Right-click on the folder Application Inventory and choose Import.
- Browse to the file you moved over and choose to import it.
- There may be an error that results, but in our experience the task is now able to be deleted.
- Right-click on the task and choose Delete.
New tasks function correctly at this point as the issue has been resolved.
Legacy ID
22951
Article URL http://www.symantec.com/docs/TECH14061
Terms of use for this information are found in Legal Notices









Thank you.