Installer shows Error Message "Failed to verify SMSMSE user has mailbox" When Exchange Powershell Registry Entries are Missing
| Article:TECH141794 | | | Created: 2010-10-13 | | | Updated: 2012-05-30 | | | Article URL http://www.symantec.com/docs/TECH141794 |
Problem
SMSMSE installer is run. The Service Account information dialog box is displayed. The SMSMSE service account username and password is entered. After Next is clicked a dialog box displays the following error messasge:
Failed to verify SMSMSE user has mailbox
After clicking OK the installer stops and does not install SMSMSE.
Conditions
- Service account user has an Exchange Mailbox
Perform the following steps to check this condition:
1. Start the Exchange Management Shell. Click on Start|All Programs|Microsoft Exchange Server 2010|Exchange Management Shell.
2. Enter the following command to get the mailbox
Get-Mailbox <service account name>
For example here is the command to get the mailbox for the service account Administrator:
Get-Mailbox administrator
Here is the output from the command:
Name Alias ServerName ProhibitSendQuota
---- ----- ---------- -----------------
Administrator Administrator 2k8r2 unlimited
3. If the command succeeds then this condition is met.
- The SMSMSE installer log SMSMSE65_Setup.log shows the following error message:
"ExecMonadCmdLet.exe" "C:\Program Files\Microsoft\Exchange Server\V14\bin\exshell.psc1" .\CheckMailBox.ps1 \""symantec\administrator""
fnCheckMailbox: Process Execution Failed, exit code : 100
DisplayMessageBox
See the following KB on obtaining an installer log: Obtaining detailed installation logging for the installed Symantec Mail Security for Microsoft Exchange product.
- Exchange Management PowerShell tools are not installed.
If the registry folder HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microsoft.Exchange.Management.PowerShell.E2010 is not present then this condition is met.
Cause
The registry entries for the Microsoft Management Tools PowerShell snap-ins are missing.
The SMSMSE installer uses the PowerShell snap-ins. When the tools are not installed the installer cannot verify that the service account user has an Exchange mailbox. The installer then stops.
Solution
Work with Microsoft to get the registry entries installed onto the Exchange server.
Workaround
This workaround has been determined through a support case with Microsoft. Symantec makes no representations that this workaround applies in all situations.
The workaround involves inserting the registry entries manually.
1. Download the attachment: registryfiles.zip. Extract the files from the archive.
2. The installation path configured in the .reg files is C:\Program Files\Microsoft\Exchange Server\V14\bin. If the installation path of the Exchange Server binaries is different then open each file in an editor and perform the following steps.
a. Replace each instance of C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin with the appropriate path for the Exchange Server binaries. Ensure that each directory separator includes two backslash character separators.
b. Save the files and exit the editor.
3. Insert the new registry entries on the Exchange Server by double clicking on each .reg file.
4. Log off the Exchange server and log back in.
Technical Information
- Microsoft Information
The missing registry entries have been reported to Microsoft. Customers have seen this situation when Microsoft Exchange 2010 is installed then SP1 is installed over the existing Exchange 2010 installation.
- The registry script adds the following entries to the registry:
Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microsoft.Exchange.Management.PowerShell.E2010:
Key
Value
CustomPSSnapInType
Microsoft.Exchange.Management.PowerShell.AdminPSSnapIn
ApplicationBase
C:\Program Files\Microsoft\Exchange Server\V14\bin
AssemblyName
Microsoft.Exchange.PowerShell.Configuration, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
Description
Admin Tasks for the Exchange Server
ModuleName C:\\Program Files\Microsoft\Exchange Server\V14\bin\Microsoft.Exchange.PowerShell.Configuration.dll PowerShellVersion 1.0 Vendor Microsoft Corporation Version 14.0.0.0
Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microsoft.Exchange.Management.Powershell.Support:
Key
Value
CustomPSSnapInType
Microsoft.Exchange.Management.Powershell.Support.SupportPSSnapIn
ApplicationBase
C:\Program Files\Microsoft\Exchange Server\V14\bin
AssemblyName
Microsoft.Exchange.Management.Powershell.Support, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
Description
Support Tasks for the Exchange Server
ModuleName C:\\Program Files\Microsoft\Exchange Server\V14\bin\Microsoft.Exchange.Management.Powershell.Support.dll PowerShellVersion 1.0 Vendor Microsoft Corporation Version 14.0.0.0
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