How to setup a remote ODBC connection to the OpsCenter Analytics database

Article:TECH141827  |  Created: 2010-10-13  |  Updated: 2013-01-15  |  Article URL http://www.symantec.com/docs/TECH141827
Article Type
Technical Solution


Environment

Issue



Example: How to setup a remote ODBC connection to the OpsCenter Analytics database


Error



None


Cause



 OpsCenter uses SQL Anywhere database software from Sybase.


Solution



Overview

OpsCenter uses the Sybase SQL Anywhere© database software to store its information. To remotely connect to OpsCenter via ODBC you will need to install and configure the proper ODBC software. The ODBC software is provided by Sybase, not by Symantec. This article provides an example of how to configure a remote Windows client with direct ODBC access to the OpsCenter server's database.

Warning: Direct access to the OpsCenter database bypasses any safety checks or constraints of the OpsCenter software. Any changes to the underlying database via direct access may cause OpsCenter to not function properly. Symantec does not provide support for the use of the OpsCenter database via ODBC, but only through the OpsCenter product itself.

In the example below, the OpsCenter server is "win23kx64-1" and the remote client is "win23kx64client". Both example computers are running the Windows 2003 Server operating system.

I. Prepare the OpsCenter server

Configure the OpsCenter server. By default, the OpsCenter database service will only allow access from with the OpsCenter server. Disable this restriction by changing the LocalOnly=YES option in the OpsCenter database server service startup.

a. Create a backup copy of the server.conf file. In Windows the default location is <install path>\Symantec\OpsCenter\server\db\CONF.

b. Edit the server.conf file. Change the "LocalOnly=YES" option to "LocalOnly=NO". For example, on win23kx64-1 change:

-n OPSCENTER_WIN23KX64-1 -x tcpip(LocalOnly=YES;ServerPort=13786) -gd DBA -gk DBA -gl DBA -gp 4096 -ti 0 -c 256M -ch 1024M -cl 256M -zl -os 1M -m -o "C:\Program Files\Symantec\OpsCenter\server\db\log\server.log" -m

to

-n OPSCENTER_WIN23KX64-1 -x tcpip(LocalOnly=NO;ServerPort=13786) -gd DBA -gk DBA -gl DBA -gp 4096 -ti 0 -c 256M -ch 1024M -cl 256M -zl -os 1M -m -o "C:\Program Files\Symantec\OpsCenter\server\db\log\server.log" -m

Note that "OPSCENTER_WIN23KX64-1" is the database server name in this example server.conf file. This will be used later below in the remote client's configuration, but in lower case.

c. Restart the OpsCenter services using the "opsadmin" commands:

Windows: <install path>\Symantec\OpsCenter\server\bin\opsadmin stop
Unix/Linux: /opt/SYMCOpsCenterServer/bin/opsadmin.sh stop

and then use opsadmin again but with the "start" option.

II. Download the Sybase Anywhere ODBC software

Download the appropriate ODBC software for your operating system. At the time of this writing the software is located at http://www.sybase.com/detail?id=1087327 and the webpage is titled, "SQL Anywhere Database Client Download". The current download version is Sybase Anywhere 12.0.1, but it is backwards-compatible with OpsCenter (which uses version 11.0.1). This software is provided by Sybase, not Symantec. Contact Sybase for more information if you need assistance.

a. Download "SA1201_Client.exe" to a temporary location on the client, win23kx64client, such as c:\temp.

III. Configure the example remote client

a. Install the downloaded software using all default selections. This will install Sybase Central 6.1.0, Sybase Anywhere Console, ODBC Data Source Administrator, Mobilink Monitor, and Interactive Console. Contact Sybase for any additional information or assistance.

b. From the Windows Start menu choose Programs > Administrative Tools > Data Source (ODBC) and in the User DSN tab click "Add". Choose "SQL Anywhere 12" and click "Finish".

c. This brings up a dialog box with the tabs ODBC, Login, Network, Advanced. Enter the following:

Network tab
Verify that Packet encryption is set to NONE

Login tab
Authentication: Database
User ID: DBA
Password: SQL
Action: Connect to a running database on another computer
Host: win23kx64-1
Port: 13786
Server name: opscenter_win23kx64-1
Database name: vxpmdb

Note: As described earlier, the “Server name” field uses a lower case version of the database server name from server.conf on the OpsCenter server.

ODBC tab
Data source name: vxpmdb (or whatever you would like)

d. Click on Test Connection in the ODBC tab. If it fails then recheck your entries, verify network name resolution, network connectivity, and firewall settings. Once passed, click OK, and then OK again.

IV. Example Usage

a. Start Sybase Central on the remote client

b. From the menu choose Connections > connect with SQL Anywhere 12.

c. Fill out the dialog box:

Authentication: Database
User ID: DBA
Password: SQL
Action: Connect with an ODBC Data Source
ODBC Data Source Name: vxpmdb (or whatever name you had created above)

d. Click the Connect button.




Article URL http://www.symantec.com/docs/TECH141827


Terms of use for this information are found in Legal Notices