KNOWN ISSUE: TS7: Use of the advanced option "save script output with task status" prevents certain command script options from executing

Article:TECH141851  |  Created: 2010-10-13  |  Updated: 2011-09-02  |  Article URL http://www.symantec.com/docs/TECH141851
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Article Type
Technical Solution

Product(s)

Issue



When executing a Command Script with the advanced option of  "Save script output with task status" selected, certain commands will not execute causing script failures and other problems.  Not all have been tested, but some of the commands that do not execute correctly include:

  • xcopy
  • pause

The results therefore can be rather confusing, including but not limited to:

  • Crashing SMP Agent (or PECTAgent in Automation).
  • Incorrect results
  • "hung" processes (the agent appears to stop responding)
  • Failed scripts that work just fine when run stand-alone
  • Missing data
  • Scripts that time out even though they ran.

Other possible problems you may see include:

  • Problems calling other executables.  For instance, calling ILO commands when scripted cause this to happen.
  • Problems outputing text to files.
  • Problems with special characters and/or language sets.

The issue affects production AND automation environments, and can affect Powershell and command scripts, as well as possibly other script "types".  Those two are the most common though.


Environment



TS7 on SMP 7.x (including 7.0, 7.1, 7.1 SP1, automation, and production environments)


Cause



Development is aware and is researching the issue.


Solution



Bits and pieces of this are being resolved in various releases.  For instance, the "pause" issue was resolved in SP5.  The xCopy issue was at least partly resolved in SP5, but is still problematic.

We suggest that you:

1) try turning off this option and see if the scripts run to completion.  If they do, 

2) try finding out WHAT command is causing the problem.  It might take some time to narrow it down, but this information is valuable.

3) if you can narrow down what is causing the problem, Consider opening a case with Symantec to let us know.

4) You might be able to isolate the "broken" commands into their own scripts, so that all the rest of your scripts return status information, and only those with the "broken" stuff have the option removed.  This could increase the # of scripts though, which isn't recommended, and has been problematic when the number gets very large in a single job.  It's an option though.

 

Current Workaround:

For tasks that run in DS 7.1 automation environments do the following:

Do the following:

On the NS copy 'aexagentdesktop' from '<install drive>\program files\altiris\altiris agent' to '<install drive> \program files\altiris\altiris agent\agents\deployment\task handler\bootwiz\oem\DS\winpe2\x86\Base\Program Files\Altiris\Altiris Agent'.  After the file has been copied recreate the preboots.

 

 

 


Supplemental Materials

SourceDEFECT
ValueETK 1988747 , 2327854
Description

Logged in Etrack (Symantec) database



Legacy ID



51846


Article URL http://www.symantec.com/docs/TECH141851


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