Hotfix NB_7.1.0.2_ET2595732_2.zip is a NetBackup Hotfix for Exchange Clients

Article:TECH142262  |  Created: 2010-10-20  |  Updated: 2011-12-05  |  Article URL http://www.symantec.com/docs/TECH142262
Article Type
Technical Solution


Environment

Problem



Granular Recovery Technology (GRT) restores fail if the customer is using a Hardware Networked Load Balanced CAS Server or an External address for the CAS server.


Error



<Install Path>/veritas/netbackup/logs/bpresolver will show:

08:56:13.448 [7480.7476] <2> <FROM BEDS>: DBG - EseE14::GetTargetDatabaseCopyStatus(IN)  ... machine:"ex2010dagp01", database:"FacultyAI" targetSite:"", options:0x4, flags:0, count:0
08:56:13.635 [7480.7476] <2> <FROM BEDS>: DBG - EseE14::GetTargetDatabaseCopyStatus(OUT) ... dag:Yes, status:"Mounted", active:"SRVWEXMBP01", passive:"", healthy:No, mdb:Yes, cas:mymail.myworld.com , clustered:Yes
08:56:13.635 [7480.7476] <2> <FROM BEDS>: DBG - E14::ResolveDeviceName([Backup]    "\\ex2010dag01\Microsoft Information Store\FacultyAI") => "SRVWEXMBP01" ... 0x0

 


Cause



Here is a typical environment which may encounter this problem:

Mailbox Server 1 = ex201001
Mailbox Server 2 = ex201002

DAG name = ex2010DAG.symantec.com

Public name = mymail.myworld.com
Exchange is also using Load Balancing over SSL

CLIENT ACCESS SERVERS
CAS Server = ex2010CAS01
CAS Server = ex2010CAS02
Powershell command to see what the RPC Client access server is set to:

Get-MailboxDatabase -identity [mailbox database]|fl

RpcClientAccessServer                        : mymail.myworld.com

As we can see from the log snippets above,  bpresolver is trying to connect to mymail.myworld.com, the Hardware laod balancer rejects the network traffic and does not pass it though to a physical CAS server, we eventually time out trying to connect to it. The BPRD log on the master server will eventually timeout after five minutes and the the restore job will error with a status 5.


Solution



Please apply NetBackup 7.1.0.2 and apply NB_7.1.0.2_ET2595732_2.zip attached to this document:

Symantec Bug ID: 2595732
Version: NetBackup_7.1.0.2

Installation Location: Exchange Client

Fixes Included:

(ET2595732) GRT DAG restore fails if the environment's RpcClientAccessServer is set to an external or Network Load Balanced address
 

Installation Instructions:
Please follow the EEB Installer instructions available on http://www.symantec.com/docs/TECH64620

Package Contents:
Please choose the appropriate platform after download:

eebinstaller.2595732.2.AMD64.exe Windows x64 Installation

CheckSums:
AMD64/bpresolver.exe 133921907 327680
AMD64/librai.dll 2915902976 1510400
AMD64/BEExch2007Component.dll 3656427986 106496
AMD64/bedsxese.dll 1319319395 640512 
 

ETA of Fix:
 
Symantec has acknowledged that the above-mentioned issue (Etrack 2595732) is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec is committed to product quality and satisfied customers. This issue was scheduled to be addressed in the following release:
 
NetBackup 7.1.0.3
 
Please note that Symantec Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Symantec's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.


 


Attachments

Hotfix NB_7.1.0.2_ET2595732_2.zip is a NetBackup Hotfix for Exchange Clients
NB_7.1.0.2_ET2595732_2.zip (757 kBytes)

Supplemental Materials

SourceETrack
Value2158705 7.0.1, 2371066 7.1


Article URL http://www.symantec.com/docs/TECH142262


Terms of use for this information are found in Legal Notices