Messages fail to export to Enterprise Vault When IMLogicAdminService Runs out of Memory Due to Memory Leak

Article:TECH142514  |  Created: 2010-10-22  |  Updated: 2011-08-31  |  Article URL http://www.symantec.com/docs/TECH142514
Article Type
Technical Solution

Product(s)

Issue



IM Manager is configured to export directly to Enterprise Vault.  Sometimes the export succeeds and sometimes it fails with an "out of memory" error.  Some organizations have seen this issue after a month of successful exports.  Some organizations have seen this issue after one successful export.

Symptoms

  • The IMLogicAdminService is using over 900 MB of memory.


To verify this follow these steps:


1. Open the Task Manager on the server where the IMLogicAdminService is installed.
2. In the list find the entry for the IMLogicAdminService.exe and note the value in the Memory column.
3. If this value is greater then 9,000K, this condition is met.

 

Conditions

  • Export job is Direct EV export job

1. Open the IM Manager Administration Console.

2. Click on Administration tab.

3. Click on Configuration > Export.

4. Click the Edit control for the EV export job.


If there is an EV Directory DNS Alias textbox then the export job is an integrated EV export job.

 

 


Error



  • Any of the following error messages are reported in the Windows Application Event log by the IMLogicAdminService:

 

 

 

 

Error 0x8007000e processing input file E:\IMManagerExports\IMExport\IML22fa6.xml.

 

 

 

 

--------

 

 

 

 

Description: Ran out of memory
. Failed conversation was moved to E:\IMManagerExports\IMExport\errors\Error-IML32bf6.xml
------------

Generic unhandled exception caught

 

 

 

 

-----------

Internal Error 0x8007000e in IM Manager Export Module.

---------

Internal Error 0x8 in IM Manager Export.

Description: Not enough storage is available to process this command."

----------

 Error 0x8007000e Connection IM Manager Export Module to SQL Server symantec\testserver, Database IMManagerDB for Account ExportToEV.

Description: 0 - Out of memory.

 

---------

[Microsoft][ODBC SQL Server Driver]Memory allocation failure-HY001
[Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_DBC failed-IM005
"

---------------

0 - [Microsoft][ODBC SQL Server Driver]Memory allocation failure
1 - [Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_DBC failed
"

 

 


Cause



There is a memory leak in the IMLogicAdminService.


Solution



Upgrade to IM Manager 8.4.17 or higher.

Workaround

A workaround is to restart the IMLogicAdminService daily.

 

 

 

 

 

 

 

 

 

 

 


Supplemental Materials

SourceETrack
Value2095598



Article URL http://www.symantec.com/docs/TECH142514


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