GRT based restore of Exchange 2010 fails with an error: 0xe00002f8 - Cannot open one or more mail messages because of unknown MAPI errors.
| Article:TECH142724 | | | Created: 2010-10-26 | | | Updated: 2013-02-11 | | | Article URL http://www.symantec.com/docs/TECH142724 |
Problem
Restore of individual mail messages, mailboxes or folders fails from a GRT based backup of Exchange 2010.
Error
Error from Job Log:
Final error: 0xe00002f8 - Cannot open one or more mail messages because of unknown MAPI errors. Review the job log for more information.
Erros from Exchange (CAS) server's EWS log:
--- EWSExchangeSession::SendSeedMsg ---
From BESA_USER@YOUR_DOMAIN.DOM
Exception in sending seedmsg Request failed. The underlying connection was closed: An unexpected error occurred on a send.
---EWSStore::OpenFolder---
Exception in FindFolder Request failed. The underlying connection was closed: An unexpected error occurred on a send.
Errors from Exchange (CAS) server's beremote log:
- SendSeedMSG: Faied on remote server 80131500.
- SendSeedMSG FAILED! RC = 0x00000000
- Error: OpenObj returns extended error e00002f8
- Error: OpenObj returns extended error e00002f8
- Error: OpenObj returns extended error e00002f8
Cause
CAUSE 1
This issue may occur if the CAS resolves to IPv6 when attempting to ping localhost.
To confirm: Run the following command on the Exchange CAS: ping localhost
Check if it returns an IPv6 value e.g :: 1
CAUSE 2
This issue may also occur if the mailbox being restored to has expired.
To confirm: Run the restore job with EWS debugging enabled.
The EWS debug log will show the following error:
"impersonation principal name is invalid"
Solution
SOLUTION FOR CAUSE 1
1) Open the hosts file located at %SystemRoot%\system32\drivers\etc\ by using an editor such as Notepad.
2) Add the following lines into the file:
actual IPv4 address hostname of the computer
actual IPv4 address FQDN of the computer
actual IPv4 address localhost
For eg:
10.0.100.11 exchange
10.0.100.11 exchange.domain.local
10.0.100.11 localhost
3. Save the changes made to the file and restart the Backup Exec services on the Exchange CAS server.
Run the restore again.
If it still fails, run it with the "When restoring individual mail messages and folders, restore over existing messages and folders" option enabled under the Microsoft Exchange tab in the restore job properties.
SOLUTION FOR CAUSE 2
Re-enable the mailbox.
|
|
| Source | Error Code |
| Value | 0xe00002f8 |
| Description | Cannot open one or more mail messages because of unknown MAPI errors. Review the job log for more information. |
| Source | UMI |
| Value | V-79-57344-760 |
| Description | Unable to open the item Database - Skipped |
Related Articles
Article URL http://www.symantec.com/docs/TECH142724
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