The Backup Exec Intelligent Disaster Recovery (IDR) option does not detect Broadcom NetXtreme II Network Interface Cards (NIC's).

Article:TECH142734  |  Created: 2010-10-26  |  Updated: 2012-05-17  |  Article URL http://www.symantec.com/docs/TECH142734
Article Type
Technical Solution


Issue



The Broadcom NetXtreme II Network Interface Cards (NIC's) might not be detected by the initial release of the Backup Exec 2010 R3 or prior versions and the Intelligent Disaster Recovery (IDR) Option.  This issue was reported with the Broadcom NetXtreme II BCM5716C, but not limited to BCM5716C.

 


Environment



Backup Exec Intelligent Disaster Recovery (IDR) option

Broadcom NetXtreme II Network Interface Cards

 


Cause



During backup, Backup Exec does not detect Virtual Bus Driver (VBD) and NDIS Driver of Broadcom NetXtreme NIC and does not gather the drivers.  Thus, NetXtreme NIC drivers are not installed during IDR.

 

Note:

Broadcom NetXtreme NIC provides two type of drivers. Both drivers are required to use the NIC.

  • Virtual Bus Driver (VBD)
    This is a driver to generate virtual NIC with the physical NetXtream card or integrated chip.
  • NDIS driver
    This is a standard type of network driver for the virtual NIC.

Please refer http://www.broadcom.com/ for more information about the drivers of Broadcom NetXtream NIC.

 


Solution



As long as the operating system on the server being protected by IDR is not Windows 2008 R2, most issues have been fixed with the Device Driver Installer Hofixes below and with more recent versions:

Backup Exec 2010 R3 revision 5204 Hotfix 160008, Device Driver Installer DDI20110615 (June 15th, 2011)

www.symantec.com/docs/TECH160008

Backup Exec 2010 R2 revision 4164 Hotfix 143981 (DDI20101215 Device Driver Installer)

www.symantec.com/docs/TECH143981

 

Windows 2003

If the Hotfix still does not resolve the issue on a Windows 2003 server, newer Broadcom NIC drivers could be causing an conflict. In that scenario, to resolve the issue, please follow the steps below;

  1. On the server being protected by IDR, open Windows Device Manager and expand the "Network Adaptors" section.
  2. Right-click on the network interface card and select "Properties"
  3. Click on the "Details" Tab
  4. Using the "Property" drop-down box select "Matching Device Id"
  5. Make a note of the value mentioned (i.e.  pci\ven_14e4&dev_164a)
  6. Close the Driver Properties
  7. Using Windows Seach - For Files or Folders, please locate the .INF file in the C:\Windows\Inf  directory, that includes the 'word or phrase' value noted above
  8. Edit (using a text editor) the .INF file located. 
  9. Inside the .INF file, find the line that starts with %brcm% and amend that line so that it only reads as  %brcm% = broadcom, ntamd64
  10. Save the changes (Note: although possibly not required it is potentially good practice to rename/remove the matching .PNF file after editing the .INF file)
  11. On the Media server, locate your ..\Backup Exec\IDR folder
  12. Delete all contents of the Drivers sub-folder, located in this location
  13. Run a New IDR Backup of the affected server.
  14. Make a New IDR ISO CD image using the Wizard and burn a new IDR CD using that newly created ISO

Windows 2008 R2

For systems running Windows 2008 R2 if the network card driver in use is the version 4 driver supplied by Microsoft as part of the Windows 2008 R2 installatation media, then IDR should work (even without the above Hotfix) However because of the effect on the network card configuration if the Microsoft driver has been upgraded using server vendor or Broadcom supplied updates to version 5 or version 6, then Symantec have found we cannot programmatically solve the issue. The following steps are therefore a solution for customers using such a configuration:

  1. On the server being protected by IDR, open Windows Device Manager and expand the "Network Adaptors" section.
  2. Right-click on the network interface card and select "Properties"
  3. Click on the "Details" Tab
  4. Using the "Property" drop-down box select "Inf name"
  5. Make a note of the file name mentioned.
  6. Close the Driver Properties
  7. Open Windows Explorer and go to C:\Windows\Inf
  8. Locate and edit (using a text editor) the .INF file noted in step 5 above
  9. Inside the .INF file, find the line that starts with %brcm% and amend that line so that it only reads as  %brcm% = broadcom, ntamd64
  10. Save the changes (Note: although possibly not required it is potentially good practice to rename/remove the matching .PNF file after editing the .INF file)
  11. On the Media server, locate your ..\Backup Exec\IDR folder
  12. Delete all contents of the Drivers sub-folder, located in this location
  13. Run a New IDR Backup of the affected server.
  14. Make a New IDR ISO CD image using the Wizard and burn a new IDR CD using that newly created ISO

This new IDR CD should now correctly detect the Network Interface Adaptor.


Supplemental Materials

SourceETrack
Value2135422
Description

IDR: Cannot find the Broadcom NetXtreme II (BCM5716C) during IDR GUI mode network setup 


SourceETrack
Value2335465
Description

IDR recovery does not recognize Integrated Broadcom BCM5716 NetXtreme II in a PowerEdge R410 server




Article URL http://www.symantec.com/docs/TECH142734


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