ItemVersionData Table growing very large with Altiris.SoftwareManagement.Tasks.SoftwareExecution and Altiris.SoftwareManagement.Tasks.DownloadSoftware items.

Article:TECH143154  |  Created: 2010-11-01  |  Updated: 2011-10-28  |  Article URL http://www.symantec.com/docs/TECH143154
Article Type
Technical Solution


Environment

Issue



ItemVersionData Table growing very large with Altiris.SoftwareManagement.Tasks.SoftwareExecution and Altiris.SoftwareManagement.Tasks.DownloadSoftware items.

ItemVersionData can also grow for other reasons.  For information on other reasons, please refer to TECH46681.


Environment



Symantec Management Platform 7.0 Service Pack 4

Software Management Solution 7.0 Service Pack 2 MR1


Cause



The root cause of this issue is Items generated during OnClientConfig. The Save method is calling the same code path in an effort to avoid creating Items on every request, but since the fundamental method is flawed we are instead generating many Altiris.SoftwareManagement.Tasks.SoftwareExecution and Altiris.SoftwareManagement.Tasks.DownloadSoftware on ClientConfigRequest. Save should be creating any required items and OnClientConfig should only ever have to load items. If the items don't exist during client config request - it should abort as an error scenario. The fundamental design problem is the root cause of this issue.
 
Regardless of if the symptoms are shown where you have a restricted user save the item(managed delivery policy), or if the item(managed delivery policy) is saved with no command line (and subsequently had a command line added) the root cause would appear to be that Save calls are mishandled, OnClientConfig is calling this mishandled Save method and the result is many calls to Altiris.SoftwareManagement.Tasks.SoftwareExecution and Altiris.SoftwareManagement.Tasks.DownloadSoftware during OnClientConfig.


Solution



This issue was corrected in 7.0 MR4 and succeeding versions.

Work-around:
Open and save all Managed Delivery Policies one by one using a user which is part of the Symantec Administrator role.

It is recommended to contact Symantec Support for assistance with the clean-up of the orphaned Items using database space for this issue.


Supplemental Materials

SourceETrack
Value2137788

SourceETrack
Value1897888


Article URL http://www.symantec.com/docs/TECH143154


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