SQL Server Instance fails to expand in the selection list, and backups fail with "Unable to attach to a resource."

Article:TECH143879  |  Created: 2010-11-10  |  Updated: 2014-06-24  |  Article URL http://www.symantec.com/docs/TECH143879
Article Type
Technical Solution


Subject

Issue



Trying to expand the SQL Server Instance in the backup selection list will fail. Any previously created backups will fail with "Unable to attach to a resource."


Error



"An attempt to connect to SQL Server has failed. The logon account may have invalid credentials, or the logon account may have been applied to the wrong resource."


Cause



This can be caused by the Backup Exec account not having the correct credentials in the SQL Instance.


Solution



 
 1. Make sure that Backup Exec account has the following server roles & privileges on the SQL server while backing up SQL databases:
  • dbcreator
  • securityadmin
  • serveradmin
  • sysadmin

2. Also add the Backup Exec account to local administrator group on SQL server .

 





Article URL http://www.symantec.com/docs/TECH143879


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