During a license refresh, Notification Server locks and the Altiris service stops after 10 minutes

Article:TECH14409  |  Created: 2006-06-26  |  Updated: 2008-08-05  |  Article URL http://www.symantec.com/docs/TECH14409
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Article Type
Technical Solution


Issue



During a license refresh, Notification Server locks and the Altiris service stops after 10 minutes.

Environment



Notification Server 6.0 SP3
Application Metering


Cause



When an Application Metering NSE requests a license at the same time as another license request, one of the transactions does not complete.

In this instance the SQL server cannot see the lock as a deadlock (so the deadlock mechanism is not engaged) and the application doesn't see a lock. This causes the computer to drop the connection after ten minutes, and the service to hang until the SQL spid is killed.


Solution



Download SP3 KB34317 Update (R6) here. Release notes can be found in article 34317.


Supplemental Materials

SourceDEFECT
ValueSYD 27100
DescriptionLogged in sydd2 (Altiris - Sydney) database

Legacy ID



24097


Article URL http://www.symantec.com/docs/TECH14409


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