IM Manager Reviewer Console Displays OCS IM Messages in Rich Text Format (RTF)

Article:TECH145361  |  Created: 2010-12-01  |  Updated: 2010-12-09  |  Article URL http://www.symantec.com/docs/TECH145361
Article Type
Technical Solution

Product(s)

Issue



  • Similar Office Communications Server (OCS) messages in RTF format are displayed in the IM Manager Reviewer Console, in the database and when exported:
{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fcharset0 MS Shell Dlg;}}            {\colortbl ;\red0\green0\blue0;}            {\*\generator Msftedit 5.41.15.1515;}\viewkind4\uc1\pard\tx720\cf1\f0\fs20 Hello are you there?\par} [|] 0x1364 |2010:11:12 13:27:00 | DEBUG_3 | CDataBaseLogger::LogToDB | {\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fcharset0 MS Shell Dlg;}}            {\colortbl ;\red0\green0\blue0;}            {\*\generator Msftedit 5.41.15.1515;}\viewkind4\uc1\pard\tx720\cf1\f0\fs20 Hello are you there?\par} [-]

Error



 

 

Condition(s) 

  • Preserve rich text format for OCS messages is enabled
    • In the IM Manager Administrator Console click on Policies tab
    • Navigate to Group Policy | All Rules
    • In the Add/Edit Rule windows the Preserve rich text format for OCS messages check box is checked

 


Environment



  • IM Manager integration with OCS

Cause



IM Manager IMLogService messages parser is incorrectly failing to convert RTF messages to HTML before logging them to the database.


Solution



Symantec has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec is committed to product quality and satisfied customers.
There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns.  For information on how to contact Symantec Sales, please refer to the following Web site:
http://www.symantec.com/business/index.jsp
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

 

Workaround

Disable Preserve rich text format for OCS messages

  • In the IM Manager Administrator Console click on Policies tab
  • Navigate to Group Policy | All Rules
  • In the Add/Edit Rule windows uncheck the Preserve rich text format for OCS messages check box.
  • Click Submit

 


Supplemental Materials

SourceETrack
Value2211776



Article URL http://www.symantec.com/docs/TECH145361


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