Virtual Vault Fails to Synchronize If Archives Have a Large Number of Folders

Article:TECH145407  |  Created: 2010-12-02  |  Updated: 2012-03-19  |  Article URL http://www.symantec.com/docs/TECH145407
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Article Type
Technical Solution

Product(s)

Problem



When attempting to manually synchronize Virtual Vault, create additional folders within Virtual Vault, and/or manually moving items into Virtual Vault, synchronization fails.


Error



The following will be logged within the Enterprise Vault Client Trace:

HDR:PST: MDC::PSTCacheFolder::GetEID
HDR:PST: ~MDC::PSTCacheFolder::GetEID
HDR:PST: MDC::PSTCacheAdviseSink<128>::Advise: 0x0
HDR:PST: ~MDC::PSTCacheAdviseSink<128>::Advise: 0x0
HDR:PST: ~MDC::PSTCacheSearchFolder::AdviseWhenSearchComplete
HDR:PST: ~MDC::PSTCacheEVMSPToArchiveFolder::StartSearch: 0x80040119

 


Cause



Issue is caused by Outlook Search Folders within Virtual Vault becoming corrupt when attempting to process archives with 5,000 or more folders.

 


Solution



The following workarounds exist for users currently unable to use Virtual Vault when using the following Outlook versions:

Outlook 2003/2007

  1. Utilize Vault Cache with Offline Archive Explorer
  2. Allow users to manually archive items (EV Outlook Add-In needs to be installed on users workstation and Store in Vault needs to be enabled within the Exchange Desktop Policy)
  3. Allow users to continue utilizing PST's
  4. If not currently replacing archived items with shortcuts, users can be re-provisioned and assigned to an Exchange Mailbox Policy to create shortcuts.
  5. When this workaround is no longer needed, one can remove all shortcuts for users mailbox.

Microsoft has confirmed the described issue exists in Outlook 2003, 2007and 2010. Microsoft plans to release a patch for the issue described in a future Office Cumulative Update.

For additional information regarding what is included within a Microsoft Office Cumulative Update, please use the following link:
http://blogs.technet.com/b/office_sustained_engineering/

For additional information regarding changes made in how Microsoft Office updates are released, please use the following link:
http://blogs.technet.com/b/office_sustained_engineering/archive/2008/07/01/office-hotfixes-to-be-delivered-on-a-defined-schedule-in-the-form-of-cumulative-updates.aspx

The following Hotfixes have been provided by Microsoft which resolves corruption within Outlook Search Folders:
 

Outlook 2010 - http://support.microsoft.com/kb/2516474

Outlook 2007 - http://support.microsoft.com/KB/2596993



Supplemental Materials

SourceError Code
Value0x80040119
Description

HDR:PST: ~MDC::PSTCacheEVMSPToArchiveFolder::StartSearch: 0x80040119

HDR:SYNC:ARC: Synchronization failed (COM error):: 0x80040119




Article URL http://www.symantec.com/docs/TECH145407


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