RemoteClientTaskManager::SendPlatformSwitchFailure(): Error switching platforms for computer

Article:TECH145440  |  Created: 2010-12-02  |  Updated: 2011-02-27  |  Article URL http://www.symantec.com/docs/TECH145440
Article Type
Technical Solution


Issue



Clients are unable to properly register with task services and display an error message in the NS logs "Error switching platforms for computer"


Error



Log File Name: C:\Program Files\Altiris\Notification Server\Logs\a.log
Priority: 1
Help and Support:
Date: 1/1/2111 11:11:11 PM
Tick Count: 1111111111
Host Name: SMPSERVERNAME
Process: AtrsHost (1788)
Thread ID: 28
Module: AtrsHost.exe
Source: Altiris.TaskManagement.ClientTask.*
Description: RemoteClientTaskManager::SendPlatformSwitchFailure(): Error switching platforms for computer COMPUTERNAME (0f9f1c85-6940-425f-b940-acce5426c023) to run task b55d1a95-d0cf-47ed-8a00-0169c285d1ec: System.Exception: Unable to get a platform provider to switch resource BR229TEL05 (0f9f1c85-6940-425f-b940-acce5426c023) from platform {Altiris.TaskManagement.Common.ClientTask.Platforms.PlatformInformation}
   at Altiris.ClientTask.Server.RemoteClientTaskManager.UpdateClientPlatform(PlatformInformation currentPlatform, IRemoteClientTaskInstance taskRequiringSwitch)

 

Checking the agent logs, it looks like the computer is getting a tickle every minute that is disconnected


Environment



Symantec Management Platform/Task Server 7 SP5


Cause



The agent install on the machine causing the error seems to be corrupted, perhaps caused by upgrade between 32bit and 64bit versions of the clients.

 


Solution



Uninstall and re-install the client from the machine causing the issue.

To uninstall you could use AeXAgentUtil /clean
This utility is places in the Agent base directory on the client

Once uninstalled, remove computer record from the console by deleting it.
You should be able to locate it within All Resources under Computers.

Once the agent has been uninstalled properly, and the computer record removed from the console/database perform an install of the agent.
You can do this manually utilizing the AeXNSC.exe installer or by pushing the agent from the console.




Article URL http://www.symantec.com/docs/TECH145440


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