After upgrading to Symantec Ghost Solution Suite 2.5.1, the option for Microsoft Windows 7 Sysprep is missing from the Supported Sysprep Versions
| Article:TECH146090 | | | Created: 2010-12-13 | | | Updated: 2011-11-07 | | | Article URL http://www.symantec.com/docs/TECH146090 |
Problem
After upgrading Symantec Ghost Solution Suite to version 2.5.1, you find that the Microsoft Windows 7 Sysprep entry is missing from the Supported Sysprep Versions. As a result, you cannot manage Sysprep for Windows 7 from a Symantec Ghost Console task.
If you install a clean install of Symantec Ghost Solution Suite 2.5.1, Sysprep for Windows 7 does appear. However, as soon as you import your database backup, the entry is missing again.
Cause
This issue occurs when the Symantec Ghost Console database is improperly updated during the installation of build 2266 of Symantec Ghost Solution Suite.
Solution
You can resolve the problem by taking a backup of the build 2266 Symantec Ghost Console database, importing that backup into a build 2165 installation of Symantec Ghost Solution Suite, and then re-upgrading to build 2266. The issue is typically resolved after installing the update a second time.
Part 1: Backing up the Symantec Ghost Console database:
- Click Start.
- Click Run.
- Type Services.msc and click OK.
- Locate the services that start with Symantec Ghost. Right-click on the first Symantec Ghost service and stop it. When you stop the first service, the second is typically automatically stopped as well.
- Copy the following files/folders to a backup folder on your Symantec Ghost Server:
- c:\Program Files\Symantec\Ghost\db
- c:\Program Files\Symantec\Ghost\pubkey.crt
- c:\Program Files\Symantec\Ghost\privkey.crt
- Click Start > Run.
- Type CMD and click OK.
- When the command prompt opens, type these commands to change to the Symantec Ghost installation directory and to export the Symantec Ghost Console database credentials:
- cd\
- cd "Program Files\Symantec\Ghost"
- ngserver -export
- Close out of the command window.
- Click Start > Run.
- Type regedit and click OK.
- Navigate to the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\SYMANTEC\GHOST\NGSERVER
- Right-click on the NGSERVER key and click Export.
- Browse to your database backup folder, provide a filename, and click Save.
Once the backup has been captured, it is ready to be imported into a build 2165 version of Symantec Ghost Solution Suite. In order to maintain customizations like driver template updates or custom copies of Windows PE on the original Symantec Ghost Server, Symantec recommends that you install the build 2165 version of Symantec Ghost Solution Suite on a separate computer. You will fix the database in a clean installation of Symantec Ghost and then import the fixed database back into your original build 2266 version of Symantec Ghost Solution Suite. This serves to fix the database corruption while still maintaining Symantec Ghost customizations that have already been made on the Symantec Ghost Server computer.
Part 2: Restoring the database backup in a build 2165 version of Symantec Ghost Solution Suite:
- Click Start.
- Click Run.
- Type Services.msc and click OK.
- Locate the services that start with Symantec Ghost. Right-click on the first Symantec Ghost service and stop it. When you stop the first service, the second is typically automatically stopped as well.
- Copy the following set of files/folders from your Symantec Ghost database backup into C:\Program Files\Symantec\Ghost:
- pubkey.crt [file]
- privkey.crt [file]
- db [folder]
- Double-click on the REG backup key to import the database credentials into the registry. Click Yes first the first question that appears. Click OK on the second message.
- Open the Symantec Ghost Console and verify that the database backup was successfully restored.
- Click Help > Live Update.
- Allow Live Update to download/install build 2266 again.
- After Live Update has successfully upgraded your Symantec Ghost software to build 2266, open the Symantec Ghost Console.
- Click Tools > Supported Sysprep Versions...
- Verify that the previously missing entry for Windows 7 Sysprep is now present.
- Close out of the Symantec Ghost Console.
Part 3: Capturing a backup of the new, fixed Symantec Ghost Console database. Take the same steps that are listed in Part 1 above to capture a new database backup.
Part 4: Restoring the new fixed Symantec Ghost Console database to the original Symantec Ghost Server, already at build 2266. Take the same steps that are listed in Part 2 above to restore the new database backup to the original Symantec Ghost Console.
Part 5: Verification that the missing Windows 7 Sysprep entry was restored:
- Open the Symantec Ghost Console.
- Click Tools.
- Click Supported Sysprep Versions...
- Verify that Windows 7 Sysprep is listed.
If the missing Microsoft Windows 7 Sysprep entry is restored, you don't need to take any further steps. If the missing Windows 7 Sysprep entry is still missing, please contact Symantec Technical Support for further assistance. Symantec Technical Support will need access to the database backup that you captured using the steps above.
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Article URL http://www.symantec.com/docs/TECH146090
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