Version compatibility check failed / Client version is not supported by server, client version too old for server.

Article:TECH146185  |  Created: 2010-12-14  |  Updated: 2012-05-29  |  Article URL http://www.symantec.com/docs/TECH146185
Article Type
Technical Solution


Issue



After an upgrade, some clients are receiving an error when they startup stating the version of DLO on the client is not compatible.  This can happen due to corruption on the DLO database tables, but once this is resolved, affected clients may still  be unable to connect to the DLO Admin Server.


Error



The following error may be seen in the DLOClient.log:

0: E> client.cpp( 2380 )  CClientApp::StartupThread : CheckForUpdates FAILED result=3759407111 - IGNORING.
11/16/10 09:46:36 dloclientu.exe 5000: T> ../client/include/testoffline.h( 237 ) Shadow::OfflineFailure : E0140007 is not an offline code, returning false
11/16/10 09:46:36 dloclientu.exe 5000: T> client.cpp( 2403 )  CClientApp::StartupThread : CheckVersionCompatibility() called.11/16/2010 09:46:36.281AM
11/16/10 09:46:36 dloclientu.exe 5000: E> shebang.cpp( 871 ) Client version is not supported by server, client version too old for server.
11/16/10 09:46:36 dloclientu.exe 5000: E> client.cpp( 2408 )  CClientApp::StartupThread : CheckVersionCompatibility FAILED result=1
11/16/10 09:46:51 dloclientu.exe 5000: W> client.cpp( 2484 )  CClientApp::StartupThread : Caught param error exception, m_id=00000001, ClientApp::StartupThread.CheckVersionCompatibility
11/16/10 09:46:51 dloclientu.exe 5000: T> client.cpp( 2493 )  CClientApp::StartupThread : EXITING 0.
11/16/10 09:46:51 dloclientu.exe 3604: E> client.cpp( 1890 )  CClientApp::InitInstance : Initialize FAILED, res=1
 


Cause



This can be caused by the DLO Agent having cached invalid settings in the .settings folder on the client, when the database was in error.


Solution



Try the following on the client machine.

For Windows XP:

Rename the C:\Documents and Settings\<UserProfile>\Local Settings\Application Data\Symantec\DLO\.settings folder and then Launch the DLO Agent. 

For Windows 7/Vista:

Rename the C:\Users\<UserProfile>\AppData\Local\Symantec\DLO\.settings folder and then Launch the DLO Agent. 

It will connect to the database successfully and recreate a new .settings after synchronizing with the DLO server.

 




Article URL http://www.symantec.com/docs/TECH146185


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