How to enable Debugging for Enterprise Vault

Article:TECH146829  |  Created: 2010-12-22  |  Updated: 2013-04-04  |  Article URL http://www.symantec.com/docs/TECH146829
Article Type
Technical Solution


Subject

Issue



How to enable Debugging to troubleshoot Enterprise Vault (EV) backup\restore issues


Solution



Debug Steps:
Set Debug on the Backup Exec (BE) server and each server that is part of the EV setup: 
 
Open Debug Monitor on each server. For more detail on Debug Monitor see - http://www.symantec.com/docs/HOWTO11932 
  1. On the BE server:
    1. Select the following items from the main screen of Debug Monitor: Job Engine, RAWS, Agent Browser, Backup Exec Server, Device and Media, Catalog, and Capture to File.
    2. Click Clear Log
    3. Inside Debug Monitor, go to Tools\Settings. Select  Agents on the left side. Then select Enterprise Vault on the right and set it to Low
    4. Inside the Tools\Settings dialog, select Job Engine & Remote Agent on the left. Then select Enable Job Engine and Remote Agent Debug outside of SGMon. (Note this will remain in debug mode until this option is turned off)
  2. On each remote server that is part of EV:
    1. Select the following items from the main screen of Debug Monitor: RAWS and Capture to File.
    2. Click Clear Log
    3. Inside Debug Monitor, go to Tools\Settings. Select  Agents on the left side. Then select Enterprise Vault on the right and set it to Low
    4. Inside the Tools\Settings dialog, select Job Engine & Remote Agent on the left. Then select Enable Job Engine and Remote Agent Debug outside of SGMon. (Note this will remain in debug mode until this option is turned off)
    5. Restart the Backup Exec Remote Agent for Windows Service.
  3. Run the job and reproduce the issue. 
    1. Select the smallest job that will reproduce the problem.
    2. Run this while no other jobs are running, if possible.
    3. Wait for the error to occur.
  4. Collect and send the logs:
    1. Run the SymHelp Tool (formerly the BE Support Tool) on each server to collect and send logs. More detail on this tool can be found in http://www.symantec.com/docs/TECH126539
    2. Be sure to select Full logs for support 
    3. After the Tool has completed the upload of logs from each server to the FTP site, Save and send the Job Log of the job by replying to the Symantec Technician Email or posting it to the case at www.MySymantec.com
  5. Debugs should be turned off after the issue is resolved and the logs can be deleted. Each step of the debugs mentioned above need to be undone.   
     
    
Notes about the logs:
The logs are created under -
BE Server - Program Files\Symantec\Backup Exec\Logs
Remote servers - Program Files\Symantec\Backup Exec\RAWS\Logs
The following logs create a new file each time BE services restart/debug is turned on:
ServerName-BEngine##.log      
ServerName-BERemote##.log  
The following logs append (single log file):
ServerName-SGMon.log
EVBackup.xml
 
 




Article URL http://www.symantec.com/docs/TECH146829


Terms of use for this information are found in Legal Notices