How to build an Inventory Report in Ghost that collects information about running processes on your Ghost Client computers

Article:TECH147228  |  Created: 2010-12-30  |  Updated: 2013-09-10  |  Article URL http://www.symantec.com/docs/TECH147228
Article Type
Technical Solution


Issue



You want to know if you can run a Ghost Console task that will collect information about running processes on your Ghost Client Computers. 


Solution



First, ensure that the “Process” inventory view is set to collect data.  In a default installation of Ghost, it is NOT set to collect data.

  1. Open the Ghost Console. 
  2. Click Tools > Options
  3. Click the Inventory Tab
  4. Make sure that the box next to “Show Collected Data Sets in Inventory” is checked
  5. Click Apply
  6. Click OK

Second, locate the "Process" inventory view and enable data collection for it:

  1. Along the left side of the Ghost Console, expand Inventory > Collected Data > Operating System
  2. Double-click on “Process” on the right-hand side of the Console view
  3. Make sure that the box next to “Do not collect data for this class” IS NOT CHECKED. 
  4. Click OK

Third, add the "Process" inventory view to your desired clients through the Client Properties:

  • If you want to add the Process Inventory view to one or a few of your client computers, proceed with these steps:
  1. Double-click on the client(s) you want to collect "Process" information for
  2. Click the Inventory tab
  3. Click Set Views...
  4. Scroll down the list and select “Process”
  5. Click the Add >> button
  6. Click OK
  • If you want to add the Process Inventory view to all of your client computers, proceed with these steps:
  1. Click Tools > Inventory
  2. Click Modify
  3. Under "Available Views" scroll down until you find "Process" and select it
  4. Click Add >>
  5. Click OK
  6. Click Apply
  7. Click OK

Fourth, run a Refresh Inventory task on the client computer so that it gathers new inventory information for the new inventory view you just added:

  1. Click File > New > Task
  2. Check the task step for "Refresh Inventory"
  3. Under "Target Machine Group/Machine", click the Browse button
  4. Browse to the group of client computers you want to run the task on - or browse to the single client computer you want to run the task on
  5. Click OK
  6. Click Execute
  7. This task can run as a "casual task" so if you see a prompt that the task is not saved, just click OK

Fifth, manually view the Process information that has been collected:

  1. Double-click on one of your client computer targeted with the Refresh Inventory task
  2. Click the Inventory tab
  3. Under Inventory Views, select "Process"
  4. Use the scroll bars to scroll through all of the running tasks inventoried from that client computer

Sixth, generate a report that can be exported into TXT or CSV format:

  1. Click File > New > Inventory Report
  2. Provide a Report Name like "Running Client Processes"
  3. Click Browse
  4. Browse to the single client computer or the group of client computers you want included in the report
  5. Click OK
  6. Check the box next to "Use View"
  7. Click Browse
  8. Expand View > Operating System > Process
  9. Click OK
  10. Click OK
  11. Along the left side of the Ghost Console, expand Inventory > Report
  12. Locate the report you just created on the right-hand side of the Ghost Console (it will be titled with the Report Name set in step 2 above)
  13. Right-click on the report and select the option to Run Report...
  14. Click the Export... button to find options to export the report data to a CSV or TXT file

 




Article URL http://www.symantec.com/docs/TECH147228


Terms of use for this information are found in Legal Notices