CPU spikes and/or high CPU utilization on the client PC with Carbon Copy Solution

Article:TECH14748  |  Created: 2006-07-17  |  Updated: 2009-04-30  |  Article URL http://www.symantec.com/docs/TECH14748
Article Type
Technical Solution


Issue



Why is Carbon Copy causing client pc CPU usage to spike?

This paper will assume a basic knowledge of the solution and navigation through the Altiris Notification Server and use of the Altiris solutions.

This paper will give detailed instructions and background on how to resolve the CPU spike seen on clients running the Carbon Copy Solution caused by the client.exe process.

Altiris Carbon Copy provides a robust, quick, and clean interface to remote control a PC. Being combined into other Altiris solutions, it leverages the strengths and design of Help Desk Solution and Notification Server. Carbon Copy runs through a series of locally run services on the PC. These services are written to run with a small memory footprint to have the least affect on CPU resources. However, there exists a bug in which a particular Carbon Copy service can cause CPU spikes and/or high CPU utilization on the client PC.

Symptoms of this include but may not be limited to the following behaviors. Running the Task Manager on a Windows 2000 PC, a user may see multiple instances of the client.exe process being displayed. These may continue to multiply until the PC is in an unusable state. The client might also see a single client.exe process with an extremely high utilization, normally 90% or above without any active Carbon Copy connections being made. A third situation may be the user seeing a second client.exe process spawning every 5 to 10 seconds and spiking CPU resources during this interval.

Normal workarounds to these behaviors such as starting and stopping services, rebooting the client PC and reinstalling Carbon Copy have little effect on resolving these behaviors. Even if all these steps are taken, the behavior may return.


Environment



Windows 2000 PC

Cause



The actual cause is as follows (thanks to Charlie Melega and 1180 for their help on this): The problem is very sporadic in nature and occurs after the rollout of the Carbon copy configuration policy. When the policy is rolled out, configexec.exe will perform a stop and start function on the following services, ccsrvc.exe, shellker.exe, and client.exe. The timing of these stops and starts is critical and have been known to be problematic on specific systems but cannot be predetermined due to the drastic change in environment variables. Subsequently, client.exe does not accept a stop call from shellker.exe and the following start command is issued to client.exe even though it was never properly stopped during the initial call. This can cause the above behaviors to occur with the client.exe process.

Solution



  1. Upgrade to the latest version of Carbon Copy Solution
  2. Enable the Carbon Copy Agent Upgrade policy
  3. Once all the Carbon Copy Agents have been upgraded, this symptom should no longer occur

Legacy ID



24786


Article URL http://www.symantec.com/docs/TECH14748


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