Mailboxes from Remote Servers Displayed for Manual/Scheduled Scans and May Cause Scan Failures

Article:TECH147480  |  Created: 2011-01-05  |  Updated: 2011-03-28  |  Article URL http://www.symantec.com/docs/TECH147480
Article Type
Technical Solution


Problem



When configuring a manual/scheduled scan mailboxes from remote Exchange servers are displayed in the Mailbox list. 

Symptoms

  • If Symantec Mail Security for Exchange (SMSMSE) does not attempt to scan the remote mailboxes then the statistics for the "total number of mailboxes" and the "total number of mailboxes processed" may be different.
  • If SMSMSE does attempt to scan the remote mailboxes there may be scan failures.

    The following error event will show up in the Windows Application Event log:

    Event Log: Application
    Event Type: Error
    Source: Symantec Mail Security for Microsoft Exchange
    Category: Manual and Scheduled Scanning
    Event ID: 394
    ComputerName: SYMANTECSRV01
    Date/Time 9/11/2010 10:14:02 AM
    Message: Scan Failed: Weekly Scan. 

Conditions

  • There are multiple Exchange 2007 mailbox servers each hosting separate mailboxes.
  • The mailbox list for the Scheduled/Manual scan contains mailboxes from remote servers.

The way to determine this is to compare the master.mb file from both servers.  If the files list any of the same mailboxes then this condition is met.

The default location for this file is:

C:\Program Files(x86)\Symantec\SMSMSE\<version>\Server\Config\master.mb

  • Selecting only mailboxes local to the server allows the scan to complete successfully.

1. Log into the Symantec Mail Security for Exchange (SMSMSE) adminstration console.
2. Click on the Scans tab.
3. Perform the following steps to configure a manual scan:

a. Click on Views|Manual Scan.
b. Click on Tasks|Edit manual Scan...
c. Click the Next button.
d. Select only mailboxes local to the server in the Mailboxes section of the dialog box.
e. Configure the remainder of the scan options.

4. Perform the following steps to configure a scheduled scan:

a. Click on Views|Scheduled Scans.
b. Click on either Tasks|New scan... or Tasks|Edit Scan....
c. Enter a name for the scan if appropriate then click the Next button.
d. Select only mailboxes local to the server in the Mailboxes section of the dialog box.
e. Configure the remainder of the scan options.
 

5. The scan runs successfully.

 


Cause



SMSMSE obtains the full list of mailboxes from Exchange.  The list is not filtered by SMSMSE to only mailboxes hosted on the local Exchange server.


Solution



This issue is fixed in SMSMSE 6.5.5, upgrade to SMSMSE 6.5.5 to resolve this problem

Workaround

Use one of the following workarounds.

  • Select only local mailboxes when configuring the scheduled/manual scan.

NOTE:  This workaround requires that the scan is reconfigured each time a new mailbox is added to the server.

 

1. Log into the Symantec Mail Security for Exchange (SMSMSE) adminstration console.
2. Click on the Scans tab.
3. Perform the following steps to configure a manual scan:

a. Click on Views|Manual Scan.
b. Click on Tasks|Edit manual Scan...
c. Click the Next button.
d. Select only mailboxes local to the server in the Mailboxes section of the dialog box.
e. Configure the remainder of the scan options.

4. Perform the following steps to configure a scheduled scan:

 

a. Click on Views|Scheduled Scans.
b. Click on either Tasks|New scan... or Tasks|Edit Scan....
c. Enter a name for the scan if appropriate then click the Next button.
d. Select only mailboxes local to the server in the Mailboxes section of the dialog box.
e. Configure the remainder of the scan options.
 

 


Supplemental Materials

SourceETrack
Value1940682
Description

Master.mb includes list of all mailbox servers on Ex2007


SourceETrack
Value1924391
Description

Master.mb includes mailboxes from all mailbox servers


SourceEvent ID
Value394
Description

Scan Failed


SourceETrack
Value2180087
Description

 Manual scan options allow users to select mailboxes from mailbox servers not accessible to SMSMSE, causing the scan to fail. EX2k7.



Article URL http://www.symantec.com/docs/TECH147480


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