Redirected SQL database restore fails with status 5
| Article:TECH148200 | | | Created: 2011-01-15 | | | Updated: 2011-01-15 | | | Article URL http://www.symantec.com/docs/TECH148200 |
Problem
Redirected SQL database restore fails with status 5
Error
Progress Log:
ERR - Error in GetCommand: 0x80770004.
CONTINUATION: - All devices are open
CONTINUATION: - An abort request is preventing anything except termination actions.
INF - OPERATION #1 of batch C:\Program Files\Veritas\NetBackup\DbExt\MsSql\restore\rest.bch FAILED with STATUS 1 (0 is normal). Elapsed time = 100(100) seconds.
INF - Results of executing <C:\Program Files\Veritas\NetBackup\DbExt\MsSql\restore\rest.bch>:
<0> operations succeeded. <1> operations failed.
dbclient log:
10:07:58.123 [5201.4375] <16> readFromServer: ERR - recv() returned 0 while reading 512 bytes on 1164 socket
10:07:58.123 [5201.4375] <16> read_encrypt_cipher_header: ERR - reading e_info
10:07:58.123 [5201.4375] <4> handshake: ERR - read_encrypt_cipher_header failed
Cause
The above errors may be encountered if the backup uses NetBackup client-side encryption feature. Subsequently, a valid key file must be available before data can be restored.
Solution
Before initiating the restore, ensure that destination client already has a matching key file.
You can either:
1. Copy the key file (<install dir>\Veritas\NetBackup\var\keyfile.dat) from source client to the same location on the destination client.
or,
2. Recreate the file on the destination client by running: <install dir>\Veritas\NetBackup\bin\bpkeyutil.exe
Enter the same pass phrase as used by the source client.
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Article URL http://www.symantec.com/docs/TECH148200
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