Symantec Scan Engine (SSE) service does not start after Java is updated with the event: "Error 1053: The service did not respond to the start or control request in timely fashion".

Article:TECH148567  |  Created: 2011-01-19  |  Updated: 2014-07-21  |  Article URL http://www.symantec.com/docs/TECH148567
Article Type
Technical Solution


Issue



The SSE service is stopped.  When restarting the SSE service from the Windows Service Control Panel it fails to start and reports the following error message:

Error 1053: The service did not respond to the start or control request in timely fashion.


Error



The Windows Application Event log shows the following error message:

Conditions

  • Java was updated and required a computer reboot.

This condition is met when the Windows Application Event log has an event like the following showing that Java was updated and the installer required a reboot:

 

Log Name:      Application
Source:        MsiInstaller
Date:          4/14/2012 3:41:44 PM
Event ID:      1005
Task Category: None
Level:         Information
Keywords:      Classic
User:          SYSTEM
Computer:      SCANENGINESERVER01.contoso.com
Description:

The Windows Installer initiated a system restart to complete or continue the configuration of 'Java(TM) 6 Update 31'. 

  • The Java installation is missing files.

Some or all of the following files are missing:

 

c:\program files(x86)\Java\jre6\lib\jce.jar
c:\program files(x86)\Java\jre6\lib\jsse.jar
c:\program files(x86)\Java\jre6\lib\rt.jar
c:\program files(x86)\Java\jre6\ext\sunjce_provider.jar
c:\program files(x86)\Java\jre6\ext\sunmscapi.jar

 

 


Cause



The Java installer is not detecting that the SSE service is still using the Java DLLs.  As a result the Java installer is not putting the required updated files in the Java installation.  See the following Java defect submission for more details: JDK files tools.jar, jsse.jar, resources.jar, and rt.jar get deleted on reboot.


Solution



Symantec is aware of this issue.  This article is updated as more information is available.  Subscribe to this article to receive updates.

Workaround

Always stop the Symantec Scan Engine service before performing a Java update.  

To address this issue once it has occured uninstall Java from the Add/Remove control panel.  Then reinstall the version of Java desired.

 


Supplemental Materials

SourceETrack
Value2823950


Article URL http://www.symantec.com/docs/TECH148567


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