KNOWN ISSUE: USB Devices do not work when Protect is installed

Article:TECH14911  |  Created: 2006-07-26  |  Updated: 2008-06-05  |  Article URL http://www.symantec.com/docs/TECH14911
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Article Type
Technical Solution

Issue



USB devices do not always work when Protect is installed.

When a computer has Protect installed, after awhile, when inserting a USB thumb drive rather than just installing the drivers automatically, the add new devices wizard tries to run, but if the user is not an administrator, he or she cannot run the wizard.

The protected users get prompted to provide user name and password.


Environment



Protect 1.1.4, 1.1.5

Cause



This is a bug in the Protect 1.1.4 and 1.1.5 code.

When a USB device is plugged into your computer, Windows creates registry to identify the device. These keys are volatile. Volatile keys should get destroyed when you restart your computer. With Protect on the computer, these keys are not created volatile. As such, when you plug in an USB device later and a key that should have been destroyed was not, Windows gets confused, and the device does not work.

Solution



Symantec is aware of the issue and is currently working to try to find a resolution. This article will be updated when one is found.


Supplemental Materials

SourceDEFECT
ValueLB 57939
DescriptionLogged in Littlebuggy (Altiris - Lindon, Plymouth) database


Legacy ID



25076


Article URL http://www.symantec.com/docs/TECH14911


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