PGP Software Development Kit (SDK): FIPS Validation

Article:TECH149193  |  Created: 2008-07-17  |  Updated: 2012-05-10  |  Article URL http://www.symantec.com/docs/TECH149193
Article Type
Technical Solution


Issue




The PGP Software Development Kit (SDK), which is the core cryptographic technology underlying PGP Universal and other PGP products, has been validated to the National Institute of Standards and Technology's (NIST's) Federal Information Processing Standard 140-2. FIPS 140-2 validation provides independent assurance that the standard cryptographic algorithms used within the PGP SDK and other security-critical functions throughout the PGP SDK, such as key handling, are implemented correctly.

 


Solution



Symantec Endpoint Encryption Products have a long history of FIPS validating its core cryptographic implementations, which are part of the PGP SDK:

 

Note: Verification of the PGP SDK validation is available on the NIST website.

 
The PGP SDK 4.2.1 was validated to FIPS 140-2 on Feb. 28, 2012.
PGP Desktop 10.2.Maintenance Packs (MPs), PGP Desktop 10.2.1, PGP Universal Server 3.2 Maintenance Packs (MPs), PGP Universal Server 3.2.1, and PGP Command Line 10.2.1 contain PGP SDK 4.2.1.
 
The PGP SDK 4.0.0 was validated to FIPS 140-2 on June 22, 2010.
PGP Desktop 10, PGP Desktop 10.0.1, PGP Desktop 10.0.2, PGP Desktop 10.0.3, PGP Universal 3.0.0, PGP Universal 3.0.1, PGP Universal 3.0.2, and PGP Command Line 10.0.0 contain PGP SDK 4.0.0.

The PGP SDK 3.12.0 was validated to FIPS 140-2 on March 11, 2009.
PGP Desktop 9.9.1, PGP Desktop 9.10, PGP Desktop 9.12, PGP Universal 2.9.1, PGP Universal 2.10, PGP Universal 2.12, and PGP Command Line 9.10 contain PGP SDK 3.12.0.

The PGP SDK 3.11.0 was validated to FIPS 140-2 on October 17, 2008.
PGP Desktop 9.9.0, PGP Universal 2.9.0, and PGP Command Line 9.9.0 contain PGP SDK 3.11.0.

The PGP SDK 3.10.3 was validated to FIPS 140-2 on October 17, 2008.
PGP Desktop 9.8.3, PGP Universal 2.8.3, and PGP Command Line 9.8.0 contain PGP SDK 3.10.3.

The PGP SDK 3.8.1 was validated to FIPS 140-2 on October 22, 2007.
PGP Desktop 9.6.1, PGP Universal 2.6.1, and PGP Command Line 9.6.1 contain PGP SDK 3.8.1.

The PGP SDK 3.7.1 was validated to FIPS 140-2 on May 4, 2007.
PGP Desktop 9.5.1, PGP Universal 2.5.1, and PGP Command Line 9.5.1 contain PGP SDK 3.7.1. PGP products versioned 9.5.2, 9.5.3, 9.6, and 9.6.1 contain versions of the PGP SDK that include minor differences from the PGP SDK 3.7.1. These differences are not relevant to FIPS operation.

The PGP SDK 3.5.3 was validated to FIPS 140-2 on March 3, 2006.
PGP Desktop 9.0.3, PGP Universal 2.0.3, and PGP Command Line 9.0.3 contain PGP SDK 3.5.3.

The PGP SDK 3.0.3 was validated to FIPS 140-2 on Mar 18, 2004.
PGP Desktop 8.0.3 contains PGP SDK 3.0.3.

The PGP SDK 1.5 was validated to FIPS 140-1 on Aug 26, 1999 and Feb 20, 2003.

For more information on FIPS validation, see the NIST's Cryptographic Module Validation Program.
 
 
 


 

 



Legacy ID



1021


Article URL http://www.symantec.com/docs/TECH149193


Terms of use for this information are found in Legal Notices