can not insert, update, or delete items in the policy tables and the adm_conf_organization table

Article:TECH150218  |  Created: 2011-01-25  |  Updated: 2011-03-07  |  Article URL http://www.symantec.com/docs/TECH150218
Article Type
Technical Solution


Environment

Issue



When performing adding, updating or deleting items in the database through the Risk Automation Suite portal the event doesn't occur and ARITHABORT errors occur in the Windows Event Viewer.


Error



 Error making SQL query to the SecureFusion database: System.Data.SqlClient.SqlException: UPDATE failed because the following SET options have incorrect settings: 'ARITHABORT'. Verify that SET options are correct for use with indexed views and/or indexes on computed columns and/or query notifications and/or xml data type methods. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at...

* The text of the message can vary slightly depending on which table is being modified but they will all give the 'ARITHABORT' error.


Cause



 

The errors appear to be automatically generated, likely left behind by a Database Tuning Advisor script that had crashed. The crash can be caused by a script failing on upgrade or if indexes have been created to improve the database performance.

 

Trying to add, edit, or delete an organization was causing the same ARITHABORT error as we were getting before on the policy tables. This type of error is caused by performing an update (i.e. an insert, update or delete query) on a table whose columns were referenced by an indexed view.


Solution



This can be solved by deleting the views that were created by the additional indexing.




Article URL http://www.symantec.com/docs/TECH150218


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