STATUS CODE 24: Socket write failed

Article:TECH150369  |  Created: 2011-01-26  |  Updated: 2014-07-22  |  Article URL http://www.symantec.com/docs/TECH150369
Article Type
Technical Solution

Product(s)

Issue



A write operation to a socket failed on a Windows client.  Status code 24 is reported.

These are possible causes for this issue:

  • High network load
  • Intermittent connectivity
  • Packet reordering
  • Duplex mismatch between client and master server NICs
  • Small network buffer size 

Error



bpbkar logs:
2:18:23.023 PM: [1912.2224] <2> TransporterRemote::write[2](): DBG -  | An Exception of type [SocketWriteException] has occured at: |   Module: @(#) $Source: src/ncf/tfi/lib/TransporterRemote.cpp,v $ $Revision: 1.51 $ , Function: TransporterRemote::write[2](), Line: 307 |   Local Address: [::]:0 |   Remote Address: [::]:0 |   OS Error: 10054 (An existing connection was forcibly closed by the remote host.

bpbrm logs:
14:18:23.075 [32163] <32> bpbrm handle_backup: from client Lonzippy: FTL - socket write failed  14:18:23.130 [32163] <2> job_monitoring_exex: ACK disconnect
14:18:23.130 [32163] <2> job_disconnect: Disconnected
14:18:23.130 [32163] <4> db_error_add_to_file: from client Lonzippy: FTL - socket write failed
14:18:23.179 [32163] <2> bpbrm handle_backup: client Lonzippy EXIT STATUS = 24: socket write failed
14:18:23.180 [32163] <2> inform_client_of_status: INF - Server status = 24
14:18:23.204 [32116] <2> Bpbrm_siginfo_print: 0: delay 0 signo SIGCHLD:17 code 1 pid 32163
14:18:23.204 [32116] <2> bpbrm brm_sigcld: SIGCLD caught by bpbrm
14:18:23.204 [32116] <2> bpbrm brm_sigcld: bpbrm child 32163 exit_status = 24, signal_status = 0
14:18:23.205 [32116] <2> bpbrm brm_sigcld: child 32163 exited with status 24: socket write failed


Environment



Operating Systems: Windows Server 2003 and Windows Server 2008
Products Applied:  NetBackup 6.x and NetBackup 7.x Servers and Clients


Cause



A possible cause is a high network load. For example, this problem occurs with Cannot write to STDOUT when a Windows system that monitors network load detects a high load.


Solution



1. Change Communication buffer size from 32K to 128K. In the NetBackup Admin Console, navigate to Host Properties > Clients > Client Properties > Windows Client > ClientSettings > Communication buffer size = 128

2. If antivirus software is running, disable it as a troubleshooting step.

3. Disable autotuning and chimney features.  From a command prompt, run:

netsh int tcp set global autotuning=disabled   
Windows Server 2003: netsh int tcp set global chimney=disabled   

For Windows Server 2008: Refer to TECH145791 for information on TCP Chimney and other settings.

4. Reboot the client.


Supplemental Materials

SourceError Code
Value24
Description

socket write failed




Article URL http://www.symantec.com/docs/TECH150369


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