Under NetBackup 7.0.1 and 7.1, VMware Virtual Machines cannot be restored if any of the virtual disks (VMDKs) are larger than one Terabyte.

Article:TECH150448  |  Created: 2011-01-27  |  Updated: 2011-06-15  |  Article URL http://www.symantec.com/docs/TECH150448
Article Type
Technical Solution


Problem



Document History:
This document was updated March 18, 2011 to reflect that NetBackup 7.1 is also affected by this issue.
This document was updated April 26, 2011 to add information about an EEB bundle available by request.

This document was updated June 15, 2011 to mention a fix available in the maintenance release mentioned below.

Introduction:

If a Virtual Machine that is being backed up has a VMDK or VMDKs (Virtual Disk(s)) larger than one Terabyte, backups taken under policies configured with the VMware (FlashBackup-Windows) policy type may show as successful with status code 0 reported in the Activity Monitor - however, a restore of the Virtual Machine will be incomplete with status code 1 reported.

 

 


Error



When attempting a restore, the bprd log will show messages similar to the following:

10:05:25.793 [11148.10164] <4> bprd.sfr: vxms_sort_blockmap: found /COR-STR-VMCLUS-01-LARGETEST/cor-str-tst99/cor-str-tst99_1.vmdk at offset 48

10:05:25.793 [11148.10164] <4> bprd.sfr: vxms_sort_blockmap: vmware_fbu_bli=0

10:05:25.793 [11148.10164] <16> bprd.sfr: vxms_sort_blockmap: aborting restore of file /COR-STR-VMCLUS-01-LARGETEST/cor-str-tst99/cor-str-tst99_1.vmdk - max file size is 1TB - 512

 


Environment



What is Affected:

VMware policies are affected for the following NetBackup versions on all compatible operating systems and platforms:

  • NetBackup 7.0.1
  • NetBackup 7.1

How to Determine if Affected:

Examine Virtual Machines protected by VMware policies for any VMDKs larger than 1T (one Terabyte).

 


Cause



The issue occurs due to a file size limitation introduced in NetBackup 7.0.1.  Individual files larger than one Terabyte cannot be restored from FlashBackups.

 

 


Solution



Formal Resolution:

The formal resolution to this issue (Etrack 2272424) is included in the following release:

  • NetBackup 7.1 Maintenance Release 1 (7.1.0.1)

This release is available via the download links included in the "Related Articles" section below.


Workaround:

If this issue is experienced, please contact Symantec technical support, referencing this document ID and the following Etrack to obtain an Emergency Engineering Binary (EEB) bundle which contains a fix for this issue:

  • For NetBackup 7.0.1, reference Etrack 2272383
  • For NetBackup 7.1, reference Etrack 2355935

If the bundle cannot be installed, one workaround is to identify virtual machines with Virtual Disks larger than one Terabyte, install the NetBackup client on them and protect their data by including them in an MS-Windows policy.
 


Supplemental Materials

SourceETrack
Value2241381
Description

Cannot restore Virtual Machines if any of the virtual disks (VMDKs) is larger than 1 Terabyte

 


SourceETrack
Value2272424
Description

Cannot restore a VM with disks larger than 1TB after removing a hard limit in bprd with EEB for ET2241359




Article URL http://www.symantec.com/docs/TECH150448


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