Altiris.ProcessMonitor Warning messages in log files and Application Metering 6.1 Policy entries in Client Settings Policy

Article:TECH15250  |  Created: 2008-06-09  |  Updated: 2008-06-09  |  Article URL http://www.symantec.com/docs/TECH15250
Article Type
Technical Solution

Issue



There are multiple instances of Warning messages in the a.log and agent log files, pertaining to the Altiris.ProcessMonitor in regards to the object not being loaded.

Object Altiris.ProcessMonitor is not installed: Invalid class string (-2147221005). This situation should be resolved once the agent rollout has been completed.

There are also Application Metering Policy entries in the Client Settings Policy of machines that do not have the Application Metering Agent installed.

Environment



Application Metering Solution 6.1.26

Cause



When Application Metering 6.0 was coded, its Discovery and Inventory policies were pointed to the "All Windows Computers" Collection.

This obviously causes the Notification server to add the Application Metering Policies to all Client Settings Policies, regardless if these machine have the Application Metering Agent installed or not.

As the Agent is not installed, the Policies cannot function, as they rely on the Altiris.ProcessMonitor object, which is not loaded. This explains these Warning messages.

Solution



Ensure that all Altiris Consoles are closed before running this in Query Analyzer, and allow for at least ten minutes before the changes come into effect, since some Monitor Policies do not receive this change straight away, even though QA says that two rows have been affected.

--/Application Discovery
UPDATE ItemReference SET ChildItemGuid = 'F1221B90-83E3-4790-8A96-524465C58761' WHERE ParentItemGuid IN (SELECT Guid FROM Item WHERE ClassGuid = '16EE9854-254E-4C3C-940C-2BA0696B5E0F')

--/Application Inventory
UPDATE ItemReference SET ChildItemGuid = 'F1221B90-83E3-4790-8A96-524465C58761' WHERE ParentItemGuid IN (SELECT Guid FROM Item WHERE ClassGuid = 'B709C3AB-F889-4AB9-A95C-F22F09767676')

You may receive these error messages when performing this task, which we are currently investigating:

Msg 2627, Level 14, State 1, Line 2

Violation of PRIMARY KEY constraint 'PK_ItemReference'. Cannot insert duplicate key in object 'dbo.ItemReference'.

The statement has been terminated.

Msg 2627, Level 14, State 1, Line 5

Violation of PRIMARY KEY constraint 'PK_ItemReference'. Cannot insert duplicate key in object 'dbo.ItemReference'.

The statement has been terminated.

What this means is that there are two ChildItem objects in the ItemReference table that share the same ParentGuid, and the UPDATE command fails as the ParentItemGuid and ChildItemGuid columns are both unique identifiers.

The two ClassGuid's are both Policies that should reference only the ChildItem with GUID 'F1221B90-83E3-4790-8A96-524465C58761' (Collection: Clients with Application Metering Agent Installed) not the Collection 'All 32-Bit Windows Computers'.

This is proven by the following two statements:

SELECT * FROM ItemReference WHERE ParentItemGuid IN (SELECT Guid FROM Item WHERE ClassGuid = '16EE9854-254E-4C3C-940C-2BA0696B5E0F')
SELECT * FROM ItemReference WHERE ParentItemGuid IN (SELECT Guid FROM Item WHERE ClassGuid = 'B709C3AB-F889-4AB9-A95C-F22F09767676')

To resolve this situation, please run these two statements and then run the two UPDATE ones again:

DELETE FROM ItemReference WHERE ParentItemGuid = 'D7CB2E6D-4176-4497-89EB-48E5BE8DDCEA'
AND ChildItemGuid = '8AFB27A1-5DC7-43CA-A88C-8391252F5B7B'
DELETE FROM ItemReference WHERE ParentItemGuid = '7FED3E2F-4FB6-4BD0-B083-0589148361CA'
AND ChildItemGuid = '8AFB27A1-5DC7-43CA-A88C-8391252F5B7B'



Legacy ID



25220


Article URL http://www.symantec.com/docs/TECH15250


Terms of use for this information are found in Legal Notices