Migrating Software Licenses from 6 x to 7 and getting errors

Article:TECH152871  |  Created: 2011-02-08  |  Updated: 2011-02-08  |  Article URL http://www.symantec.com/docs/TECH152871
Article Type
Technical Solution


Issue



Trying to migrate licenses and they are getting an error when the migration is tried.


Error



 

'Failed to migrate legacy software license (0c7d8d50-0ba2-436b-abec-85dbb2f4fb92)
( Exception Details: Altiris.ContractManagement.ResourceTypeDefinition.Contract.SoftwareLicense+AeXMissingAuthorizationGroupException: Missing Authorization Group information in data class Authorization Clients. Invalid row contains clients: Windows x86

Environment



CMDB 7.0 sp1

Asset Management Solution 7.0 mr3


Cause



 

Inside the Authorization Clients data class you have a collection but not a authorization group (either Computer, Owner or Primary User).
 
To verify run this query:
select
      i.Name, i.Guid, c.Name as CollectionName, c.Guid as CollectionGuid, ac.[Authorization Group]
from
      vItem i
      join Inv_Authorized_Collections_Asset65 ac on i.Guid = ac._ResourceGuid
      join vItem c on ac.Collection = c.Guid
order by i.Name, c.Name

Solution



 

If you find the Authorization Group does not contain any data, you can update the database to give it either ‘Computer’ or ‘Owner’, or ‘Primary User’ as its value. This value has to match the collection. If the collection contains only computers, then the Authorization Group value should be ‘Computer’. Otherwise can be either ‘Owner’ or ‘Primary User’.



Article URL http://www.symantec.com/docs/TECH152871


Terms of use for this information are found in Legal Notices