Error : V-1-8-0 Invalid setting/value is passed for Changing the Diagnostic Level for the NetBackup 7 unified logging.

Article:TECH153189  |  Created: 2011-02-11  |  Updated: 2013-11-15  |  Article URL http://www.symantec.com/docs/TECH153189
Article Type
Technical Solution


Issue



Not able change the Diagnostic Level for the Netbackup unified logging on the NetBackup 7 Master Server on Windows 2008 Server.

NetBackup has unified logs that can occupy very large amount of space.


Error



Error : V-1-8-0  Invalid setting/value is passed


Environment



NetBackup 7 Master  on Operating System Windows 2008
 


Cause



The nblog.conf file was corrupted.


Solution



Checked the current debug log settings
vxlogcfg -p 51216 -o Default -l
=======================================
Configuration settings for originator 112, of product 51,216...
LogDirectory = E:\Program Files\VERITAS\NetBackup\logs\
DebugLevel = 1
DiagnosticLevel = 6
DynaReloadInSec = 0
LogToStdout = False
LogToStderr = False
LogToOslog = False
RolloverMode = FileSize | LocalTime
LogRecycle = False
MaxLogFileSizeKB = 51200
RolloverPeriodInSeconds = 43200
RolloverAtLocalTime = 0:00
NumberOfLogFiles = 3
OIDNames =
AppMsgLogging = ON
L10nLib = E:\Program Files\VERITAS\NetBackup\bin\vxextwincat
L10nResourceDir = E:\Program Files\VERITAS\NetBackup\resources
NtEventLogSourceName = Application
NtEventLogCategory = 0
LogFileSDDL = (null)
=========================================

Tried to change the Diagnostic level from 6 to 1
E:\Program Files\Veritas\NetBackup\bin>vxlogcfg -a -p 51216 -o ALL -s DebugLevel =1 -s DiagnosticLevel=1
Getting Error : V-1-8-0  Invalid setting/value is passed

Checked and found that there are two nblog.conf file
One is nblog.conf
Another is nblog.conf.org

Stopped the services for Netbackup
bpdown -f -v
Changed the location for nblog.conf file to desktop.
Rename nblog.conf.org to nblog.conf
Restarted the Netbackup Services : bpup -f -v

Ran the commands
E:\Program Files\Veritas\NetBackup\bin>vxlogcfg -a --prodid 51216 --orgid ALL -s DebugLevel=0 DiagnosticLevel=1
The configuration settings were added successfully.

E:\Program Files\Veritas\NetBackup\bin>vxlogcfg -a -p NB -o 111 -s DebugLevel=1 -s DiagnosticLevel=1
The configuration settings were added successfully.

E:\Program Files\Veritas\NetBackup\bin>vxlogcfg -a -p NB -o 117 -s DebugLevel=1 -s DiagnosticLevel=1
The configuration settings were added successfully.

E:\Program Files\Veritas\NetBackup\bin>vxlogcfg -a -p NB -o 118 -s DebugLevel=1 -s DiagnosticLevel=1
The configuration settings were added successfully.

Rechecked the current nblog.conf settings
vxlogcfg -p 51216 -o Default -l
E:\Program Files\Veritas\NetBackup\bin>vxlogcfg -p 51216 -o 111 -l
Configuration settings for originator 111, of product 51,216...
LogDirectory = E:\Program Files\VERITAS\NetBackup\logs\nbemm\
DebugLevel = 1
DiagnosticLevel = 1
DynaReloadInSec = 0
LogToStdout = False
LogToStderr = False
LogToOslog = False
RolloverMode = FileSize | LocalTime
LogRecycle = False
MaxLogFileSizeKB = 51200
RolloverPeriodInSeconds = 43200
RolloverAtLocalTime = 0:00
NumberOfLogFiles = 3
OIDNames = nbemm
AppMsgLogging = ON
L10nLib = E:\Program Files\VERITAS\NetBackup\bin\vxextwincat
L10nResource = nbemm
L10nResourceDir = E:\Program Files\VERITAS\NetBackup\resources
NtEventLogSourceName = nbemm
NtEventLogCategory = 0
LogFileSDDL = (null)

Checked the nblog.conf settings for nbemm, nbjm, nbrb
vxlogcfg -p 51216 -111 Default -l
vxlogcfg -p 51216 -117 Default -l
vxlogcfg -p 51216 -118 Default -l

Deleted the old logs successfully : vxlogmgr --del -cp 51216 -o 111 -e "02/07/2011 23:59:00 PM"

Ran the same Command for originator ID : 117 & 118.

Disk space reclaimed successfully.




Article URL http://www.symantec.com/docs/TECH153189


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