Symantec Endpoint Protection for Macintosh - smcdaemon and syguard processes will not launch on managed workstations

Article:TECH153665  |  Created: 2011-02-17  |  Updated: 2013-05-24  |  Article URL http://www.symantec.com/docs/TECH153665
Article Type
Technical Solution

Product(s)

Environment

Issue



After the install of a managed Symantec Endpoint Protection for Macintosh ("SEP for Mac") client, or converting a SEP for Macintosh client from unmanaged to managed with a sylink.xml file the smcdaemon will not launch and the client does not heartbeat into its  Symantec Endpoint Protection Manager (SEPM). When trying to manually launch the smcdaemon in the Terminal, the process will not start.


Error



In the Symantec QuickMenu under Management no connection is listed and available. SEPM Server, Connection Status and Policy Serial Number read as NA. In Activity Monitor when viewing All Processes the smcdaemon and syguard processes are not running.


Cause



SEPM server information in the sylink.xml file is listed as a Fully Qualified Domain Name (FQDN) and not an IP address.


Solution



In the SEPM, modify the Management Server List to include both the FQDN and the IP address of the SEPM. Once the Management Server List is modified, export out a new install package, or sylink.xml and reinstall the SEP for Macintosh client, or replace the sylink.xml file in /Library/Application Support/Symantec/SMC and start the smcdaemon process again by either restarting the Macintosh or in the Terminal entering the following:

sudo /Library/StartupItems/SMC/smclient --start

The new sylink.xml file will be processed and the client will attempt to heartbeat back into the SEPM and the smcdaemon and syguard processes will be listed as running in the Activity Monitor.




Article URL http://www.symantec.com/docs/TECH153665


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