SEP client install rollback. SEP_inst.log show "InstallFinalize. Return Value 3"

Article:TECH153687  |  Created: 2011-02-17  |  Updated: 2011-03-02  |  Article URL http://www.symantec.com/docs/TECH153687
Article Type
Technical Solution


Issue



SEP client install rollback, the installation failed.

Check SEP_INST.log, find error point "InstallFinalize. Return Value 3"


Error



Check SEP_INST.log, find

Cc::StartServiceW: :Attempting to start service ccSetMgr
2011-02-09-15-47-59-234 : Start() failed to StartService() on ccSetMgr. Error:1053
MSIASSERT - cc::StartServiceW: : Unable to start service ccSetMgr:
2011-02-09-15-47-59-234 : cc::StartServiceW(118) : Logging time after attempting to start service: ccSetMgr
MSIASSERT - LogStartServiceAttempt: StartService returned false:
2011-02-09-15-47-59-234 : ccMSIUtil::CAutoDebugOptions::RestorePreviousState(117) : Debug key deleted
2011-02-09-15-47-59-234 : cc::StopService(187) : The service ccSetMgr is already not running. Nothing to stop. service State=1
LogStartServiceAttempt: Logging complete - service ccSetMgr stopped
2011-02-09-15-47-59-234 : cc::GetServiceStatus(1027) : Able to query status for service ccEvtMgr
LogStartServiceAttempt: Attempting to start ccEvtMgr
2011-02-09-15-47-59-234 : ccLib::CRegistry::Open(101) : RegOpenKeyEx() != ERROR_SUCCESS, Software\Symantec\Common Client\Debug, 0x00000002
 
2011-02-09-15-47-59-234 : ccMSIUtil::CAutoDebugOptions::Initialize(79) : Unable to open the debug key. Error=2
2011-02-09-15-47-59-265 : cc::StartServiceW(69) : Logging time before attempting to start service: ccEvtMgr
cc::StartServiceW: :Attempting to start service ccEvtMgr
2011-02-09-15-47-59-328 : Start() failed to StartService() on ccEvtMgr. Error:1068
MSIASSERT - cc::StartServiceW: : Unable to start service ccEvtMgr:
2011-02-09-15-47-59-328 : cc::StartServiceW(118) : Logging time after attempting to start service: ccEvtMgr
MSIASSERT - LogStartServiceAttempt: StartService returned false:
2011-02-09-15-47-59-328 : ccMSIUtil::CAutoDebugOptions::RestorePreviousState(117) : Debug key deleted
2011-02-09-15-47-59-328 : cc::StopService(187) : The service ccEvtMgr is already not running. Nothing to stop. service State=1
LogStartServiceAttempt: Logging complete - service ccEvtMgr stopped

So it will cause

15:48:01: InstallFinalize. Return Value 3.


Cause



 From the SEP_INST.log, we only know the ccSetMgr and ccEvtmrv service cannot start. But ussually there is no cause recorded in SEP_INST.log.

There may be many reasons cause the service not starting.


Solution



 

1)Run SEP uninstall tool Cleanwipe. (If there is SAVCE or SEP installed before in the system and was not removed clearly, the problem may occurs. After Run Cleanwipe, it is better to check if teefer2 drivers removed in every network adapters in the system)
2)Check Permissions
      Do use the administrator account to install SEP, check if current login account has the permission to access
1〉Registry HKey_Local_Machine\software\symantec
2〉Folder C:\program fiels\; C:\document and settings\All users\Application Data\
3〉Service remote procedule call(RPC); Com+ event system running well.
3)Use LUSetup.exe to install Liveupdate at first, then install SEP client.
4)Use Microsoft tool Process monitor, to monitor if there is any other processes involved in the installation process at the exact time error recorded.
5)Re-install the OS.



Article URL http://www.symantec.com/docs/TECH153687


Terms of use for this information are found in Legal Notices