Messages which are given Spam verdict with the action Hold message in Spam Quarantine back up in Delivery MTA queue.

Article:TECH154462  |  Created: 2011-02-28  |  Updated: 2011-09-28  |  Article URL http://www.symantec.com/docs/TECH154462
Article Type
Technical Solution

Product(s)

Environment

Issue



Messages which are given Spam verdict with the action Hold message in Spam Quarantine back up in Delivery MTA queue.
These messages share following characteristics:

  • Most of them are Spam.
  • Chosen action for Spam verdict is Hold messages in Spam Quarantine.
  • BrightmailLog.log shows Java's ArrayIndexOutOfBoundsException.

Error



1 1 2011 00:00:00 [SmtpConsumer_0080_007] ERROR - 79
java.lang.ArrayIndexOutOfBoundsException: 79
 at com.brightmail.common.lang.SBCSCodeRangeTable.lookupShiftCode(SBCSCodeRangeTable.java:138)
 at com.brightmail.common.lang.CodeRangeTable.lookupShiftcode(CodeRangeTable.java:404)
 at com.brightmail.common.lang.LanguageIdentifier.categorize(LanguageIdentifier.java:566)
 at com.brightmail.common.lang.LanguageIdentifier.classify(LanguageIdentifier.java:791)
 at com.brightmail.common.lang.LanguageIdentifierHelper.decodeHeaders(LanguageIdentifierHelper.java:168)
 at com.brightmail.bl.quarantine.SpamMessageHandler.populateSpamMessageHeaders(SpamMessageHandler.java:315)
 at com.brightmail.bl.quarantine.SpamMessageHandler.headers(SpamMessageHandler.java:197)
 at com.brightmail.service.smtp.impl.SmtpConsumer.storeHeaders(SmtpConsumer.java:303)
 at com.brightmail.service.smtp.impl.SmtpConsumer.run(SmtpConsumer.java:188)

Environment



  • Symantec Mail Security for SMTP5.0.x (SMSSMTP): Linux, Solaris, Windows
  • Symantec Brightmail Gateway 7.x/8.x/9.0.x

 


Cause



The message header field contains one or more invalid high ASCII characters.


Solution



This issue was fixed with Symantec Messaging Gateway (SMG) 9.5 and later.  Migration to SMG9.5 will solve the issue.

Workaround for SMG7.x/8.x/9.x prior to 9.5 and SMSSMTP5:

Add Modify the subject line action which appends a string with the explicit character encoding set. 
To do this, for all Quarantine policies, repeat the steps below.

  1. Logon to Brightmail Control Center (BCC) and open the policy to edit.
  2. Confirm that a Hold message in Spam Quarantine action is set in that policy.
  3. Click Add button and choose Modify the subject line in the dropdown box.
  4. In Modification textbox, type a string you would like to to append. Example: [Hold message in Spam Quarantine]
  5. In Encoding dropdown box, choose one of the predefined encoding sets. Example: Unicode UTF-8
  6. Click Append to subject radio button.
  7. Click Add Action.
  8. Click Save.

Note:
For both SMS for SMTP5 and Symantec Brightmail Gateway series, changes to the policies take effect immediately. No Services require to restart.


Supplemental Materials

SourceETrack
Value2055056
Description

Fixed with SBG9.5




Article URL http://www.symantec.com/docs/TECH154462


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