Messages for Quarantine back up in Delivery queue with java.lang.ArrayIndexOutOfBoundsException errors in BrightmailLog.log

Article:TECH154464  |  Created: 2011-02-28  |  Updated: 2011-02-28  |  Article URL http://www.symantec.com/docs/TECH154464
Article Type
Technical Solution


Environment

Issue



All of the following conditions hold true.

  • Delivery MTA queue holds a significant quantity of messages (defer and deferred)
  • maillog shows these messages are to be relayed to Quarantine
  • Most of the messages are spams
  • Filtering action(s) chosen for spams/compliance-violated messages is Quarantine
  • BrightmailLog.log shows repeated errors similar to the ones shown in the Error section:

Error



1 1 2011 00:00:00 [SmtpConsumer_0080_007] ERROR - 79
java.lang.ArrayIndexOutOfBoundsException: 79
 at com.brightmail.common.lang.SBCSCodeRangeTable.lookupShiftCode(SBCSCodeRangeTable.java:138)
 at com.brightmail.common.lang.CodeRangeTable.lookupShiftcode(CodeRangeTable.java:404)
 at com.brightmail.common.lang.LanguageIdentifier.categorize(LanguageIdentifier.java:566)
 at com.brightmail.common.lang.LanguageIdentifier.classify(LanguageIdentifier.java:791)
 at com.brightmail.common.lang.LanguageIdentifierHelper.decodeHeaders(LanguageIdentifierHelper.java:168)
 at com.brightmail.bl.quarantine.SpamMessageHandler.populateSpamMessageHeaders(SpamMessageHandler.java:315)
 at com.brightmail.bl.quarantine.SpamMessageHandler.headers(SpamMessageHandler.java:197)
 at com.brightmail.service.smtp.impl.SmtpConsumer.storeHeaders(SmtpConsumer.java:303)
 at com.brightmail.service.smtp.impl.SmtpConsumer.run(SmtpConsumer.java:188)

Environment



  • Symantec Mail Security for SMTP5.0.x (SMSSMTP): Linux, Solaris, and Windows
  • Symantec Brightmail Gateway 7.x/8.x/9.0.x  (except for 9.5.x)

 


Cause



An illegal ASCII control character is appended in the Subject header field.


Solution



As a workaround, for all the policies which send filtered messages to Spam Quarantine, repeat the following setting changes.

SMS for SMTP 5.0.x:

  1. Log in to the Brightmail Control Center as admin and open the policy to edit.
  2. Confirm that Hold message in Spam Quarantine action is chosen.
  3. From Actions group, open Select an action drop-down box and click  Modify the subject line.
  4. In Modification texbox, type the strings to be appended to the Subject (example: [Hold in Spam Quarantine])
  5. In Encoding drop-down box, click ISO-2022-JP.
  6. Enable Append to subject radio button.
  7. Click Add Action.
  8. Click Save to save the policy.

Symantec Brightmail Gateway family (7.x/8.x/9.0.x):

  1. Log in to the Brightmail Control Center as admin and open the policy to edit.
  2. Confirm that Hold message in Spam Quarantine action is chosen.
  3. From Actions group, open Select an action drop-down box and click  Modify the subject line.
  4. In Modification texbox, type the strings to be appended to the Subject (example: [Hold in Spam Quarantine])
  5. In Encoding drop-down box, click Japanese (ISO-2022-JP).
  6. Enable Append to subject radio button.
  7. Click Add Action.
  8. Click Save to save the policy.

* For both lines of products, no service restart is required. Any changes in policy will take effect immediately.




Article URL http://www.symantec.com/docs/TECH154464


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