Vault Cache sync fails due to "An invalid character was found in text content"
| Article:TECH154692 | | | Created: 2011-03-03 | | | Updated: 2013-05-21 | | | Article URL http://www.symantec.com/docs/TECH154692 |
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Problem
Vault Cache sync fails due to "An invalid character was found in text content"
Error
From the Client Trace:
------ Loaded DOMDocument3
~DesktopCommonUtil::GetXMLDOMDocumentObj: 0x0
DesktopCommonUtil::LoadBufferIntoXMLDOM: 0x0
Failed to load DOM reason 'An invalid character was found in text content.
~DesktopCommonUtil::LoadBufferIntoXMLDOM: 0x1
HDR: ~EVServerConnection::LoadXMLResponse: 0x80004005
HDR: ~EVServerConnection::GetXML: 0x0
HDR:SYNC: ~MDC::ServerResponseHandling::Request: 0x0
HDR:SYNC:ARC: ~MDC::LiveServerTree::GetFoldersDoc: 0x0
HDR:SYNC:ARC: Aborted Sync on archive: 1A9767342F54B6E4698DAA0667CFD42791110000EVServer01
HDR:SYNC:ARC: MDC::MDCSyncReport::TraceSyncReport
HDR:SYNC:ARC: Sync Report - (type not determined before abort) sync for archive: 1A9767342F54B6E4698DAA0667CFD42791110000EVServer01
HDR:SYNC:ARC: Sync Report - Aborted before fully complete
Cause
This error occurs due to the format of the Outlook folder names contained within the XML returned when the client parses the XML returned by the GetArchiveFolderHierarchyResponse query.
Workaround
Check the format of the folder names in Outlook to ensure they conform to the ASCII character set and rename as appropriate.
See the following Microsoft article for further explanation:
http://support.microsoft.com/kb/238833
Solution
This issue is resolved as part of the following release:
Enterprise Vault 10.0.3 Cumulative Hotfix 2 Release
http://www.symantec.com/docs/TECH205731
Enterprise Vault 8.x and 9.x
Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec Corporation is committed to product quality and satisfied customers.
This issue is currently under investigation by Symantec Corporation. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns. For information on how to contact Symantec Sales, please see http://www.symantec.com .
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| Source | ETrack |
| Value | 3129787 |
| Description | After a PST Import, where a folder does not have regular ASCII characters, Vault Cache Synch fails with 'An invalid character was found in text content.' |
Article URL http://www.symantec.com/docs/TECH154692
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