New computers to which the pcAnywhere Agent is deployed do not apply the pcAnywhere Settings policy

Article:TECH155043  |  Created: 2011-03-08  |  Updated: 2012-12-20  |  Article URL http://www.symantec.com/docs/TECH155043
Article Type
Technical Solution


Issue



On existing managed computers, the pcAnywhere Agent applies the pcAnywhere Settings policy as expected. 

However, on managed computers to which the pcAnywhere Agent plug-in has recently been deployed, the pcAnywhere Agent does not apply the pcAnywhere Settings policy.  In some cases, they are not applied after several days.
 


Environment



pcAnywhere Solution


Cause



Ensure the pcAnywhere agent is installed on the target machine and is listed in the Symantec Management Agent Settings for installed agents.  Allow enough time for the managed resource to get any updated configurations.  By default, agents get new configurations every 4 hours.

In 12.5 Service Pack 2 (version 12.5.539),  there was a problem with pcAnywhere Solution on the Notification Server (NS), which resulted in missing entries from a database table.  The default filter used to target computers for the pcAnywhere Settings policies includes a check for an entry in the table, so the affected computers are not included in the target membership of the Settings policy.


Solution



If this is happening after the install and its been longer than the time to get a new configuration, verify that the behavior is not due to any items listed in the Cause section of the Knowledge Base article entitled "Problems with pcAnywhere Agent and policies caused by exceeding the license count or by expired licenses" (http://www.symantec.com/business/support/index?page=content&id=TECH136452).  If any of the items in the Cause section of that article are true, then follow the instructions in the Solution section.

If that article does not apply, or if the instructions of the Solution section do not resolve the behavior, then apply the patch described below.  The patch runs the SQL code from the aforementioned article on an hourly schedule.

Note that the patch was tested on Notification Servers with Microsoft SQL Server 2005/2008. This behavior has been resolved in pcAnywhere Solution 12.6, which is available as part of Client Management Suite 7.1 and IT Management Suite 7.1.


To apply the patch:

1. Logon to the NS using the Application Identity credentials.

2. Ensure that the SQL Server Agent is in a running state on the NS.

3. Ensure that a recent backup exists of the Symantec_CMDB database.

Symantec ALWAYS recommends backing up any files or folders before making any changes.

4. Open SQL Server Management Studio.

5. Copy and paste the content of the attached file into a Query window.  Note that if the database used by the NS  is not the default "Symantec_CMDB", it will be necessary to modify the name of the database in the attached SQL  code prior to execution.

6. Execute the attached query on SQL Server 2005/2008 database.  This will create a Scheduled Task to synchronize the affected database table on an hourly basis.

Please contact Symantec Technical Support with any questions or concerns.
 


Supplemental Materials

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Article URL http://www.symantec.com/docs/TECH155043


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