Duplicate Search Results Returned When Utilizing Windows Desktop Search (WDS) and Virtual Vault

Article:TECH156009  |  Created: 2011-03-18  |  Updated: 2014-12-18  |  Article URL http://www.symantec.com/docs/TECH156009
Article Type
Technical Solution

Product(s)

Issue



Duplicate Search Results Returned When Utilizing Windows Desktop Search (WDS) and Virtual Vault


Environment



-Outlook 2007 installed on Windows XP/Vista (x86/x64) with WDS configured
-Outlook 2010 (x86/x64) installed on Windows XP/Vista (x86/x64) with WDS configured
 


Cause



Issue can be caused by WDS indexing operations that have not yet completed when indexing contents of the users Exchange mailbox and/or Virtual Vault content.  Performing a rebuild on the WDS index will also cause duplicate items to appear wthin search results.
 

Workaround for versions prior to 10.0

 

The following workaround is available for users who experience duplicate items when searching Virtual Vault:

  1. Start Outlook
     
  2. Choose Tools | Enterprise Vault | Vault Cache Properties for Outlook 2007 and File | Enterprise Vault | Vault Cache Properties for Outlook 2010
     
  3. Once the Vault Cache Properties window appears, click on the Virtual Vault tab.  This will list any archives that are currently enabled for that user
     
  4. Uncheck the box next to the archive name for each archive associated with Virtual Vault
     
  5. Restart Outlook
     
  6. Once Outlook has restarted, an indexing update request will be initiated.
     
  7. Allow indexing to complete without Virtual Vault.  Do not close out of Outlook until Indexing has completed.  When checking the WDS status, the number of items being indexed will decrease.  When completed, WDS status will state 'Indexing Complete'.
     
  8. Once Indexing has completed, choose Tools | Enterprise Vault | Vault Cache Properties for Outlook 2007 and File | Enterprise Vault | Vault Cache Properties for Outlook 2010
     
  9. Check the box next to each archive to be included with Virtual Vault
     
  10. Restart Outlook
     
  11. Once Outlook has restarted, an indexing update request will be initiated
     
  12. Allow Indexing to complete with Virtual Vault enabled.  Do not close out of Outlook until Indexing has completed.
     

Once Indexing has completed both Outlook and Virtual Vault, duplicates should no longer appear within the WDS search results.  If at any time the WDS index is rebuilt, the workaround steps will need to be reperformed.


Solution



This issue is addressed as part of the following release:

Enterprise Vault 9.0.3 - Release Details
http://www.symantec.com/docs/TECH147782

Enterprise Vault 10.0 - Release Details
http://www.symantec.com/docs/TECH141422


Supplemental Materials

SourceETrack
Value2278791
Description

WDS shows duplicate search results when searching Virtual Vault



Article URL http://www.symantec.com/docs/TECH156009


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