Exchange backup job fails with: The following error was returned when opening the Exchange Database file: '-1003 An invalid API parameter is being used. '

Article:TECH156320  |  Created: 2011-03-23  |  Updated: 2013-03-06  |  Article URL http://www.symantec.com/docs/TECH156320
Article Type
Technical Solution


Issue



Exchange backup job fails with error  '-1003 An invalid API parameter is being used.'


Error



Unable to complete the operation for the selected resource using the specified options. The following error was returned when opening the Exchange Database file:  '-1003 An invalid API parameter is being used.'

Enable remote agent debuging on remote Exchange server

How to enable or disable "debug logging" in Backup Exec for Windows Servers
http://www.symantec.com/docs/TECH23853

As per beremote logs ( On Exchange server ) :-
------------------------------------------------------------------------------------------------------
[10388] 03/08/11 16:20:48 [fsys\jet]           - PARAM:  paramDatabasePageSize=4096
[10388] 03/08/11 16:20:48 [fsys\jet]           - PARAM:  JET_paramOutstandingIOMax=1024
[10388] 03/08/11 16:20:48 [fsys\jet]           - STARTING RESTORE MAP:
 SOURCE PATH:  \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy13\ExchangeDataLCC\First Storage Group
 TARGET PATH:  C:\TEMP\Backup Exec\IMG2\vdb_2011_03_08_1608_57
[10388] 03/08/11 16:20:48 [fsys\jet]           - Recovery FAILED - ERROR::RC = -1003 - -1003 An invalid API parameter is being used.
[10388] 03/08/11 16:20:48
Closing Vlink VFF id (9776-00002630) with: Total Bytes Read=00000000:00000000, Written=00000000:00000000
[10388] 03/08/11 16:20:48 [fsys\mb2]           - Using EDB Provider for Browse/Backup.
[10388] 03/08/11 16:20:48 [fsys\mb2]           - Logon: m_lpMAPISession->Logon returned 80004005
[10388] 03/08/11 16:20:48 [fsys\mb2]           -  OPEN DATABASE FAILED: -1003 An invalid API parameter is being used.
[10388] 03/08/11 16:20:48 [fsys\mb2]           - MB2_Chgdir:Logon returned e000fea9
[10388] 03/08/11 16:20:48 [ndmp\tpfmt]         - TF xfer time = 297 seconds.
------------------------------------------------------------------------------------------


Environment



Exchange 2007


Solution



1) Uninstall Exchange agent from BE media server under

Tools -> Install options and license keys on this media server.
 

2) Reboot Backup Exec server.

3) Reinstall Exchange agent ( option )

4) Rerun the Exchange Information Store backup.


Supplemental Materials

SourceError Code
Value1003
Description

 An invalid API parameter is being used.


SourceError Code
Value0xe00002f7
Description

Cannot extract mailbox messages from the Exchange backup. Review the log for more information. 

 




Article URL http://www.symantec.com/docs/TECH156320


Terms of use for this information are found in Legal Notices