How to safely uninstall an onbox collector, then install an updated version

Article:TECH156921  |  Created: 2011-03-30  |  Updated: 2011-03-30  |  Article URL http://www.symantec.com/docs/TECH156921
Article Type
Technical Solution

Product(s)

Issue



 I have a collector version installed onbox that needs to be upgraded


Environment



Instructions are based on SIM 4.7.x


Cause



 Older version of the collector is installed onbox


Solution



Any product collector that was preinstalled on the Symantec Security Information Manager appliance cannot be uninstalled using the methods below. This KB is only for collectors that were installed via the System Update > Install section of the WebGUI in the past.

Follow the steps to upgrade the out of date collector:

1) Login to the Symantec Information Manager Console as "administrator".

2) Browse to "System Tile > Product Configurations > (Product Collector Name) > (Product Collector Configuration) > (Sensor Configuration Tab)".  Backup sensor configurations manually by writing down information about each sensor and the collector's configuration itself.

NOTE: Do not export configurations from an older version of a collector and import the XML files into a newer version.  More than likely the XML format has been changed due to a new field or just formatting in general.  Failure to follow this simple instruction may lead to hours of headache.  One can however export the XML sensor and use it as a template for manual entry later.

3) Next, login to the Symantec Information Manager WebGUI as "administrator".

4) Browse to Settings > Unregister.  Select the checkbox for the old product collector and then click on "Unregister", at the bottom of the page.

5) Browse to Maintenance > System Updates > Status

6) Observe the list of installed package names.  Find the old version of the collector, then on the far right of the screen under the Uninstall column, click on the minus icon (or the text "Enabled") to uninstall.  Wait for the uninstall completed (or refresh the Maintenance > System Updates > Status page if there is no uninstall confirmation.)

7) Download the new Product Collector from https://fileconnect.symantec.com/
 

8) Extract the Product Collector archive to the local machine, then browse to the following folder

<Collector Package Name Directory>\appliance
 

9) From within Symantec Security Information Manager WebGUI, browse to Maintenance > System Updates > Install.  Click on "Choose File" and select the <product-collector-name>.jar file from the extracted product collector folder.  Once selected, click on "Upload and Install". 

Example: <Collector Package Name Directory>\appliance\<product-collector-name>.jar

NOTE: The <product-collector-name>.jar file is for onbox installation of collectors only.  It installs both the SIP and the collector itself.

10) Confirm the collector and the SIP were installed by browsing to the following Symantec Security Information Manager WebGUI paths:

- Browse to Maintenance > System Updates > Status:  Refresh the status page to confirm the collector install was a success in the list of installed packages.

- Browse to Settings > Collector Registration > List:  Observe both the "Currently Registered Collectors" and the "Install On-Box Collectors" section.  Confirm the product collector is listed in both sections.  In addition, be sure to also confirm there is not a version mismatch between the "Currently Registered Collectors" and "Install On-Box Collectors" sections.

- Login to the Symantec Security Information Manager Console and browse to System Tile > Product Configurations > (Product Collector Name) to confirm the new version was installed correctly.  If the new version shows, begin configuration of the new collector.




Article URL http://www.symantec.com/docs/TECH156921


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