Outlook crashes when attempting to open specific items from Virtual Vault.

Article:TECH157400  |  Created: 2011-04-04  |  Updated: 2013-06-06  |  Article URL http://www.symantec.com/docs/TECH157400
Article Type
Technical Solution


Issue



Retrieving specific items from virtual vault causes Outlook to crash. However, the same items can be retrieved from the mailbox archive and a full copy of the item can be opened from a PST file. The issue only occurs when these items are retrieved from Virtual Vault.


Environment



The issue has been verified to occur on Outlook 2007 and Outlook 2010 with Enterprise Vault add-ins installed.


Cause



The cause of the crash is to do with how the MaintainStubPropsMessage::GetPropsImpl() method maps custom MAPI properties on the stub item in the MDC file to the corresponding full item in Content Cache.

 


Solution



This issue has been addressed as part of the following release:


Hotfix for Symantec Enterprise Vault (EV) for Microsoft Exchange 9.0.2, Build 1185
http://www.symantec.com/docs/TECH166005

Enterprise Vault 9.0.3 - Release Details
http://www.symantec.com/docs/TECH147782

Enterprise Vault 10.0 - Release Details
http://www.symantec.com/docs/TECH141422 


Supplemental Materials

SourceETrack
Value2321458
Description

Retrieving specific items from Virtual Vault cause Outlook to crash.




Article URL http://www.symantec.com/docs/TECH157400


Terms of use for this information are found in Legal Notices