OpenSSL expiration and private/public key mismatch warnings when attempting to establish an encrypted session between a client running DAgent and the Deployment Server engine

Article:TECH157703  |  Created: 2011-04-08  |  Updated: 2014-07-01  |  Article URL http://www.symantec.com/docs/TECH157703
Article Type
Technical Solution


Environment

Issue



Clients running the DAgent with encrypted sessions enabled fail to connect to the Deployment Solution (DS) engine and are not available in the DS console. Disabling encryption in the DAgent properties corrects this behavior. The 'Allow encrypted sessions' box is checked in the Deployment Server Configuration Utility in the Control Panel of the Deployment Solution server.


Error



The Event Viewer reports this error: "Error: OpenSSL public and private keys do not match"


Environment



Deployment Solution 6.9.453 (SP4)

This error has been reported on the following client operating systems running DAgent build 6.9.453:

  • Windows XP
  • Windows 7

AClient systems appear to be unaffected.


Cause



Unknown at this time.


Solution



This has been resolved in Deployment Soltuion 6.9.648 (SP6).


Supplemental Materials

SourceETrack
Value2346039
Description

 OpenSSL expiration and private/public key mismatch warnings



Article URL http://www.symantec.com/docs/TECH157703


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