Shadow Copy (VSS) snapshots failing with Ontap or other third party VSS provider

Article:TECH158127  |  Created: 2011-04-14  |  Updated: 2013-04-17  |  Article URL http://www.symantec.com/docs/TECH158127
Article Type
Technical Solution

Product(s)

Environment

Issue



NetBackup defaults to using the 3rd party VSS provider in NetBackup 7.0 and higher as the Open File Snapshot provider. This will cause Shadow Copy to fail and disk volumes using snapshot option to fail.

 


Error



Status 13

Status 69

Status 156


10/13/2010 12:29:29 PM - begin writing
10/13/2010 1:02:04 PM - Error bpbrm(pid=4468) from client dalmp001: ERR - Unable to backup System State or Shadow Copy. Please check the state of VSS and associated Writers.ERR - Unable to backup System State or Shadow Copy. Please check the state of VSS and associated Writers.INF - Estimate:-1 -1
10/13/2010 1:02:05 PM - Warning bpbrm(pid=4468) from client dalmp001: WRN - can't open object: Shadow Copy Components: (BEDS 0xE000FECB: A failure occurred accessing the backup component document.)
10/13/2010 1:02:05 PM - Warning bpbrm(pid=4468) from client dalmp001: WRN - can't open object: Shadow Copy Components:\System Service\Event Logs\Event Logs (BEDS 0xE000FEDD: A failure occurred accessing the object list.)
10/13/2010 1:02:05 PM - Warning bpbrm(pid=4468) from client dalmp001: WRN - can't open object: Shadow Copy Components:\System Service\Windows Management Instrumentation\WMI (BEDS 0xE000FEDD: A failure occurred accessing the object list.)
10/13/2010 1:02:05 PM - Error bpbrm(pid=4468) from client dalmp001: ERR - Unable to backup System State or Shadow Copy. Please check the state of VSS and associated Writers.INF - EXIT STATUS 69: invalid filelist specification
10/13/2010 1:02:17 PM - Error bpbrm(pid=4468) could not send server status message      
10/13/2010 1:02:17 PM - end writing; write time: 00:32:48
file read failed(13)

 

 


Environment



 

The list of providers can be seen with the following command:
 
vssadmin list providers
 
 
Provider name: 'Microsoft Software Shadow Copy provider 1.0'
   Provider type: System
   Provider Id: {b5946137-7b9f-4925-af80-51abd60b20d5}
   Version: 1.0.0.7
 
Provider name: 'Data ONTAP VSS Hardware Provider'
   Provider type: Hardware
   Provider Id: {ddd3d232-a96f-4ac5-8f7b-250fd91fd102}
   Version: 6. 2. 0. 5007
 
Provider Name  'VERITAS Volume Snapshot Service Dynamic Provider 1.0'
   Provider Type: Software
   Provider Id: {637528cf-81b2-4e05-8bd2-74b33b6f893c}!
   Version: 1.0
 

 


Cause



If you have more than one provider registered on a Windows Server 2003-based computer, the Volume Shadow Copy Service tries to start the providers in the following order

First:  Hardware Provider
Second:  Software Provider
Third:  System provider

This means that if another provider exists on the host, the Microsoft Software Shadow Copy Provider (a.k.a. the System Provider) will likely not be used by default.


Solution



There are 4 options available:

1. Contact the third party provider and configure properly.

2. In the NetBackup version 7.1 and higher client , there is a w2koption command to force NetBackup to use a manually specified provider.

The 'w2koption' command located in the ....netbackup\bin\  directory provides functionality to force the NBU Client to use a particular provider type.

w2koption -backup -snapshotprovidertype <0, 1, 2, 3> 

0   (Let Microsoft Windows decide which provider to use)
1   (Selects System VSS provider)
2   (Selects Software VSS provider)
3   (Selects Hardware VSS provider)

Example to configure NBU to use the System Provider:
     w2koption -backup -snapshotprovidertype 1

 

NetBackup clients prior to 7.1 will require an EEB for the command to work.

For NetBackup older than version 6.5.6: Upgrade the NetBackup client to 6.5.6 and obtain the EEB mentioned below.

For NetBackup version 6.5.6: Contact Symantec Technical Support to obtain EEB 2370957.  Install the EEB on the client.

For NetBackup version 7.0: Contact Symantec Technical Support to obtain EEB 2077740. Install the EEB on the client.

For NetBAckup 7.0.1       Contact Symantec Technical Support to obtain EEB 2380849. Install the EEB on the client.

Starting with NetBackup version 7.1: The command is included in the client installation.

 

3. Delete the registry key with the coresponding VSS GUID value

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Providers\

Backup  or export the key first.

4. In some of the NetBackup versions database agents there are snapshot options to select the provider type hardware, software, system, auto

   Change the provider type to system if it is failing.

 

 

 


Supplemental Materials

SourceETrack
Value2380849



Article URL http://www.symantec.com/docs/TECH158127


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