Procedure to manually remove Shared Resource Tree (SRT) on a Netbackup BMR Boot servers and then reconfigure BMR from scratch (reset of BMRDB)
| Article:TECH159033 | | | Created: 2011-04-28 | | | Updated: 2011-08-16 | | | Article URL http://www.symantec.com/docs/TECH159033 |
Problem
Sometimes it is not possible to delete / remove SRTs and Boot servers using the Netbackup Admin console / Java console.
In such situations follow this procedure at the CLI
Cause
Corruption of the BMR database
Solution
Remove the BMR Shared Resource Tree (SRT) using bmrpans:
1. From the BMR Master obtain the IDs of all Shared Resource Trees using bmrs:
<install_path>\NetBackup\bin\bmrs -o query -r database -table srt
<install_path>\NetBackup\bin\bmrs -o query -r database -table srt
2. From the output of the previous command select the ID of the SRT to be removed. Use this ID in the -id field of the following command to create the file removesrt.xml:
<install_path>\NetBackup\bin\bmrs -o querytree -r database -table srt -id <ID_of_SRT> -gui > removesrt.xml
<install_path>\NetBackup\bin\bmrs -o querytree -r database -table srt -id <ID_of_SRT> -gui > removesrt.xml
3. To delete the SRT from the BMR database run the following command on the BMR Master:
<install_path>\NetBackup\bin\bmrpans -op load -type delete -in removesrt.xml
<install_path>\NetBackup\bin\bmrpans -op load -type delete -in removesrt.xml
Ensure that the SRT is no longer visible in the NetBackup Administration Console.
Steps for removing a BMR Boot Server using bmrpans:
From the BMR Master obtain the IDs of all BMR Boot Servers using bmrs. This command will display the BootServer table from the BMR database (BootServer is case sensitive):
From the BMR Master obtain the IDs of all BMR Boot Servers using bmrs. This command will display the BootServer table from the BMR database (BootServer is case sensitive):
1. <install_path>\NetBackup\bin\bmrs -o query -r database -table BootServer
2. From the output of the previous command select the ID of the BMR Boot Server to be removed. Use this ID in the -id field of the following command to create the file removebootserver.xml:
<install_path>\NetBackup\bin\bmrs -o querytree -r database -table BootServer -id 1 -gui > removebootserver.xml
<install_path>\NetBackup\bin\bmrs -o querytree -r database -table BootServer -id 1 -gui > removebootserver.xml
3. To delete the BMR Boot Server from the BMR database run the following command on the BMR Master:
<install_path>\NetBackup\bin\bmrpans -op load -type delete -in removebootserver.xml
<install_path>\NetBackup\bin\bmrpans -op load -type delete -in removebootserver.xml
Use the NetBackup Administration Console to confirm that the Boot Server has been removed.
Steps to reset and rebuild the BMR database
The database can be initialized to a state that is new by running this command
The database can be initialized to a state that is new by running this command
<install_path>\NetBackup\bin\bmrsetupmaster -redo -force
This action will only affect BMRDB data. No backup image information is affected.
All clients will register with BMR on the next backup where the option to collect BMR information is marked.
BMR Boot Servers can be registered by running:
<install_path>\NetBackup\bin\bmrsetupboot
Shared Resource Tree (SRT) definitions can be imported back into the BMRDB by using the appropriate Boot Server utility.
All clients will register with BMR on the next backup where the option to collect BMR information is marked.
BMR Boot Servers can be registered by running:
<install_path>\NetBackup\bin\bmrsetupboot
Shared Resource Tree (SRT) definitions can be imported back into the BMRDB by using the appropriate Boot Server utility.
For Unix Boot Servers, use the command ‘bmrsrtadm’ and choose option 4, “Import a Shared Resource Tree”. You will need to specify the complete path to where the SRT file system resides.
Example: If the SRT directory was /export/srt and the SRT name is Solaris9, you would specify /export/srt/Solaris9.
For Windows Boot Servers, you will use the Boot Server Assistant. Specify the Shared Resource Tree Administration Wizard and choose the option “Copy or Import a Shared Resource Tree”. Follow the proper prompts. The path information is the same as for Unix SRT files.
As data is import into the BMRDB, it will become visible to users through the NetBackup Administration console.
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Article URL http://www.symantec.com/docs/TECH159033
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