DS 7.1: What happened to my F8 menu option?

Article:TECH159249  |  Created: 2011-05-02  |  Updated: 2012-04-05  |  Article URL http://www.symantec.com/docs/TECH159249
Article Type
Technical Solution


Problem



We would like to be able to select manually the PXE menu option we boot to in DS 7.1 using F8.  However, most of the time we can't, though we've seen it some times.  Why is this?


Cause



In order to fully automate the experience of users when imaging, the original design of the product was to make the process fully hands-free.


Solution



DS 7.5 will resolve this issue completely, due 3rd quarter 2012

DS 7.5 has options available to control the time out (how long the F8 menu is available) for three scenarios: predefined computers, managed computers, and unknown computers. 

Explanation of how the F8 PXE menu works in DS 7.1:

Currently, in Deployment Solution 7.1, 7.1 SP1, 7.1 SP2 the F8 selection and timeout works as follows:

A) There are 3 states for any computer:

  1. The default state has a 3 second timeout on the PXE menu before booting to "next device" (generally production).
  2. If a job is sent to the computer to reboot to automation, this state has a 0 second timout and immediately boots to automation.
  3. If a job is sent to the computer to reboot to production, this state has a 0 second timout and immediately boots to production.

B) Whenever the PXE services are started, all "known" computers to the PXE server are set with the default option (1) above with a 3 second display of F8.

C) As soon as a job is sent with instructions to boot to production, OR automation, the setting for that computer is set to either (2) or (3) above and will boot immediately to it's selected option.

D) There is no setting anywhere to reset the computer back to the default (1) state of showing the menu for 3 seconds.  The setting "sticks" until another job switches the PXE server to boot to a different environment.  Thus, most of the time, you'll not see the F8 option, but you will some times, giving the "impression of inconsistency", or a broken state.

WorkAround:

Though not pretty, the only work-around at this time is to reset the PXE Server service, which effectively resets the status of all known computers to the original state on the PXE server of having a 3 second timeout.  Again, this is no longer an issue in the 7.5 release




Article URL http://www.symantec.com/docs/TECH159249


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