Veritas Storage agent terminates unexpectedly.

Article:TECH159304  |  Created: 2011-05-03  |  Updated: 2012-07-21  |  Article URL http://www.symantec.com/docs/TECH159304
Article Type
Technical Solution



Issue



The Veritas Storage Agent (VXVM) may terminate unexpectedly while running snapshot related operations in Storage Foundation for Windows High Availability configurations.

This can cause all Service Groups with Volume Manager Disk Groups (VMDGs) online on the affected node to failover to alternative nodes in the cluster during which times the applications served by these Service Groups would become temporarily unavailable.


Environment



Veritas Storage Foundation for Windows High Availability with configured Veritas Cluster (VCS) with both the Storage Foundation for Windows Flashsnap option and the Storage Foundation For Windows Volume Replicator option configured.


Cause



When operations are issued by Storage Foundation for Windows (SFW) in an HA environment, all commands have to be checked with VCS to determine whether the affected SFW object is under VCS control as certain operations could cause a fault in an online Service Group.

Some SFW providers can cause all open connections to VCS to close unexpectedly.  This results in memory corruption within the VXVM process which causes it to crash.


Solution



This issue has been identified and a private fix is available from Symantec Enterprise Technical Support. To obtain the private fix, contact Symantec Enterprise Technical Support and reference this article during the call. A support representative will be available to assist in troubleshooting this issue. If it is determined that the private fix addresses the problem the support representative will further assist in obtaining the private fix.

Note: This fix specifically addresses the problem identified above. It has not been fully tested and should be applied in a test environment before placing into production. If the systems are not critically impaired, it is recommended to delay the installation of this private fix until the next scheduled maintenance release. Before applying this private fix, systems may be required to be upgraded to the latest code base. The support representative will help in determining the best course of action.


Supplemental Materials

SourceETrack
Value2330107
Description

Storage Agent crashes during snapshot



Article URL http://www.symantec.com/docs/TECH159304


Terms of use for this information are found in Legal Notices