Error "Timeout expired. Timeout period elapsed prior to completion of the operation or the server is not responding. " occurs in the Notification Server logs after timeouts occur in Helpdesk

Article:TECH159341  |  Created: 2011-05-03  |  Updated: 2011-08-03  |  Article URL http://www.symantec.com/docs/TECH159341
Article Type
Technical Solution

Issue



The error "Timeout expired. Timeout period elapsed prior to completion of the operation or the server is not responding. <stored procedure name>"  occurs in the Notification Server logs when timeouts or out of memory errors occur in Helpdesk.


Error



Timeout expired. Timeout period elapsed prior to completion of the operation or the server is not responding. <stored procedure name>

Cause



Helpdesk incidents that have comments exceeding 4,000 characters in even one incident can cause .NET to overflow and the Helpdesk database (Altiris_Incidents) to increase substantially in size. The more incidents that have this issue, the more frequent the slow performance, timeouts or out of memory errors will occur.

Note: This error will appear to indicate that the specified stored procedure is the cause of the issue. This is incorrect; this is a symptom of the timeout, not the cause.


Solution



Truncate or delete incidents that have large comments and apply business rules to prevent future occurrences. Refer to the following article for more information:

Incidents with large comments cause slow performance, timeouts or out of memory errors in Helpdesk
http://www.symantec.com/business/support/index?page=content&id=TECH145515

Related Article

Slow performance, timeouts, out of memory errors or high CPU/w3wp.exe/IIS usage occurs when using Helpdesk
http://www.symantec.com/business/support/index?page=content&id=TECH146510




Article URL http://www.symantec.com/docs/TECH159341


Terms of use for this information are found in Legal Notices