Error during installation of Symantec System Recovery. Error 1935. An error occurred during the installation of assembly component

Article:TECH159544  |  Created: 2011-05-06  |  Updated: 2013-03-04  |  Article URL http://www.symantec.com/docs/TECH159544
Article Type
Technical Solution


Environment

Problem



Error during installation of Symantec System Recovery

 


Error



Error 1935. An error occurred during the installation of assembly component {98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}. HRESULT: 0x80070003

Error 1935. An error occurred during the installation of assembly component {98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E} HRESULT: 0x800736B5

Error 1935. An error occurred during the installation of assembly component {844EFBA7-1C24-93B2-A01F-C8B3B9A1E18E} HRESULT: 0x80070BC9

Error 1935. An error occurred during the installation of assembly component {4F6D20F0-CCE5-1492-A01F-C8B3B9A1E18E} HRESULT: 0x800736FD

Note: The assembly component GUID may vary from that shown.

 


Cause



This error may be caused by the registry on the computer reaching the size limit set for it, or due to missing or corrupt operating system files. This issue occurs from Microsoft Visual C++ 2005 SP1 Redistributable Package.


Solution



1.  Go to Start > Run, type REGEDIT, and click OK

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

2.  Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

3.  Edit the value for 'RegistrySizeLimit' to be hex ffffffff and then click OK

4.  Reboot the computer and login as Administrator or equivalent uuser

5.  Run the System File Checker using the instructions in the following Microsoft article:
http://support.microsoft.com/kb/929833

Correct any problems that are found.

6.  Reboot the computer 

7.  Run the installation of Symantec System Recovery again

If these steps do not fix the problem, please try the instructions outlined in the following articles from Microsoft:

http://support.microsoft.com/kb/953610

http://answers.microsoft.com/en-us/windows/forum/windows_vista-windows_programs/installation-error/d0e8bc93-a450-4b94-97d1-b2ecd025e452




Article URL http://www.symantec.com/docs/TECH159544


Terms of use for this information are found in Legal Notices