Getting "Error 4: The system cannot open the file." when trying to stop the Backup Exec Deduplication Engine service and Backup Exec Deduplication Manager service.

Article:TECH159714  |  Created: 2011-05-10  |  Updated: 2012-11-26  |  Article URL http://www.symantec.com/docs/TECH159714
Article Type
Technical Solution


Issue



During troubleshooting Deduplication issues, some times it is required to stop the Backup Exec Deduplication services in the following order and then restart back in reverse order:

Backup Exec PureDisk Filesystem service

Backup Exec Deduplication Engine

Backup Exec Deduplication Manager

PostgreSQL - 8.3

Now when trying to stop the Backup Exec Deduplication Engine service and Backup Exec Deduplication Manager service the following error

"Error 4: The system cannot open the file"

Note:- The above error does not come when trying to stop the Backup Exec PureDisk Filesystem service.

 


Error




Cause



The root cause of this error is due to PostgreSQL - 8.3 service is already stopped or crashed and hence it would not get the file path for the executables of Backup Exec Deduplication Engine and Backup Exec Deduplication Manager service.

So will get this error when attempting to stop the Backup Exec Deduplication Engine and Backup Exec Deduplication Manager service.

However, when clicking "OK" it will show that the Backup Exec Deduplication Engine and Backup Exec Deduplication Manager service are stopped.

 


Solution



To resolve this issue follow the steps as below:

1) Make sure that PostgreSQL - 8.3 service is started

2) If the PostgreSQL - 8.3 service is stopped or crashed and is not getting started, reboot the media server

3) Now confirm that PostgreSQL - 8.3 service is started and then continue with stopping the other Deduplication services as required.




Article URL http://www.symantec.com/docs/TECH159714


Terms of use for this information are found in Legal Notices